Bug 1581 - i855 fix
Summary: i855 fix
Status: CLOSED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-10 08:23 UTC by Stefan Dirsch
Modified: 2004-10-11 07:12 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
p_855_display_switch.diff (5.12 KB, patch)
2004-10-10 08:24 UTC, Stefan Dirsch
no flags Details | Splinter Review

Description Stefan Dirsch 2004-10-10 08:23:05 UTC
Fix for Intel 855 mobile chipsets to work around the problem  
that the video BIOS misadjusts the framebuffer start address  
and doesn't set up HW cursor correctly when switching output  
channels (internal (LCD) external (CRT) both). The patch simply  
adds a timer function to the driver which interrogates the BIOS  
once per second if anything has changed. 
 
I'll attach  patch.
Comment 1 Stefan Dirsch 2004-10-10 08:24:00 UTC
Created attachment 1064 [details] [review]
p_855_display_switch.diff
Comment 2 Egbert Eich 2004-10-11 01:26:34 UTC
Code for this is already in the driver.
Comment 3 Stefan Dirsch 2004-10-12 00:12:13 UTC
This patch should not be applied. The problem is already fixed in a different 
way. And this patch can even harm. 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.