Bug 15897 - Auto-play every file (autoplay, auto-start, autostart)
Summary: Auto-play every file (autoplay, auto-start, autostart)
Status: RESOLVED FIXED
Alias: None
Product: swfdec
Classification: Unclassified
Component: plugin (show other bugs)
Version: unspecified
Hardware: All All
: medium enhancement
Assignee: swfdec ml
QA Contact: swfdec ml
URL:
Whiteboard:
Keywords:
: 16605 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-09 14:17 UTC by Γριφεγ (z0z0tuss)
Modified: 2008-09-08 05:21 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Γριφεγ (z0z0tuss) 2008-05-09 14:17:11 UTC
I think there should be a checkbox "[ ] Automatically start playing this Flash from now on" somewhere around the "Play" button that initially appears.

Accessible from the right click menu or among settings there could be a list of these files that are set to auto-play with option to Add/Remove.

Should be URL-based, probably disregarding http:/https: and the initial www.
Comment 1 Benjamin Otte 2008-05-09 15:36:15 UTC
This is fixed in git already. If you care about what the feature does (as opposed to how it is implemented), see http://lists.freedesktop.org/archives/swfdec/2008-April/001438.html
Comment 2 Γριφεγ (z0z0tuss) 2008-06-19 10:43:42 UTC
Consider this usage scenario:
1) User loads unfamiliar page
2) It contains some flash
3) User wants to load the flash that is used for navigation
4) ...but... What he clicks on is an ad
5) From now on all ads from that ad broker will auto-play

I now think swfdec should just behave like the official Flash player. Blocking ads is better done already by browsers or their extensions.
Comment 3 Benjamin Otte 2008-06-19 11:55:48 UTC
This is a valid complaint, but there's two things to keep in mind:
1) right-click => uncheck "playing" will not just stop the current ad, but disable autoplay, too. So just stop the ad and the broker will not autoplay again.
2) Extensions don't work for the average use. Lots of people do not know about extension or don't install any. So as long as ad-blocking is not enabled by a default-install, swfdec doing it is a feature. (Plus, Flashblock doesn't work very well.)
Comment 4 Γριφεγ (z0z0tuss) 2008-06-19 15:21:11 UTC
Flashblock isn't good, but Adblock Plus is, and I think there are more people using it currently than the number of swfdec users. And with such an ad-blocker, every flash that is allowed will be useful content so at least in this case I think all should auto-play (IF there is a way to detect Adblock that sites could not fake). Unfortunately major browsers will never include ad blockers that block ads by default. Also if swfdec becomes widely used ads could be placed on the same server as useful flash and then a more sophisticated mechanism would be needed essentially what adblock does already.
Comment 5 Riccardo Magliocchetti 2008-07-03 15:33:50 UTC
*** Bug 16605 has been marked as a duplicate of this bug. ***
Comment 6 Γριφεγ (z0z0tuss) 2008-07-08 16:36:23 UTC
Just a note: The in-browser version of Google Talk relies on flash for sound recording&playback, but the plugin is not shown visually.

So there is no way to enable it currently.
Comment 7 Pekka Lampila 2008-08-16 10:46:55 UTC
Current git (373931a2f30088951659d3fb011ef9e6a09e9a36) now has a setting to pick whether to always autoplay, never autoplay or remember the setting based on the host. This setting can be found from the context menu.
Comment 8 Alexander van Loon 2008-08-24 04:22:29 UTC
After Adobe Flash was causing Firefox 3.0.1 to crash left and right I decided to switch to swfdec like undoubtedly many others. But the default behaviour of swfdec is annoying me like no tomorrow, so I'd like to voice my concerns here as well.

My proposal is similar to z0z0tuss proposal, that swfdec should automatically play everything. That's the default behaviour of Adobe Flash, and that's what casual users expect, I observed that as soon as they saw a grey background with a play button they think that Flash is broken. The current situation is a very poor choice, the small minority who wants to block certain Flash content or doesn't want autoplay could just use the functionality in the web browser or it's extensions to achieve that, right?

In response to your second argument Benjamin Otte, maybe the fact that many people don't know about extensions or don't use them means that Flash ads aren't annoying enough to motivate them to think about methods to prevent them from showing. In other words, it's probably not an issue for most people. Casual users for whom I install Ubuntu have never asked me for methods to block ads. And the end doesn't justify the means, "breaking" Flash by not autoplaying by default will annoy and confuse users far more than a few ads here and there. 

Could the swfdec developers please do a new unstable release soon, because I'd really appreciate the fix in Git which gives an option for autoplaying always. Now I'm constantly clicking on play buttons for Flash content, which is annoying like no tomorrow.

Besides my voicing my concerns, I'd like to thank the swfdec developers. Finally we can switch to 64-bit without having to worry about Flash, and we're not dependent on the bug-ridden Adobe Flash anymore. You guys are awesome for reverse engineering Flash, it puts Adobe to shame. Thank you so very much guys.
Comment 9 Riccardo Magliocchetti 2008-09-08 05:21:06 UTC
Please give 0.8.0 a try and reopen if it is the case.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.