Bug 15933 - Box freezing during X startup (intel Q965)
Summary: Box freezing during X startup (intel Q965)
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium normal
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2008-05-14 11:50 UTC by Mathias Weyland
Modified: 2008-05-19 18:00 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (2.73 KB, text/plain)
2008-05-14 11:50 UTC, Mathias Weyland
no flags Details
Xorg.log success case (42.04 KB, text/plain)
2008-05-14 11:51 UTC, Mathias Weyland
no flags Details
Xorg.log failure case (37.12 KB, text/plain)
2008-05-14 11:51 UTC, Mathias Weyland
no flags Details
bisect xf86-video-intel-2.3.0 and xf86-video-intel-2.3.1 (1.00 KB, text/plain)
2008-05-17 10:03 UTC, Florian Steinel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Weyland 2008-05-14 11:50:37 UTC
Created attachment 16535 [details]
xorg.conf

In 8 out of 10 cases, my dell optiplex 745 freezes right after X11 startup with a black screen which didn't even show a mouse pointer. lspci output:

00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)

I found bug #14867 in this bugzilla system which describes the problem, but for another version of the driver. The initial poster claims the problem to be solved (however, the NEEDINFO flag is set), but I tried both with 2.2.1 and 2.3.1 (the latter was an unpatched version) and I'm still getting the black screen in most of the cases even with AIGLX and DRI switched off. Once this happens, the box doesen't react to keyboard input or ICMP packets.

I'm attaching my xorg.conf as well as my Xorg.log for both the failure and the success cases. Please ask if you need more information on this - I really to want to help fixing this problem since it's quite an annoying problem.
Comment 1 Mathias Weyland 2008-05-14 11:51:16 UTC
Created attachment 16536 [details]
Xorg.log success case
Comment 2 Mathias Weyland 2008-05-14 11:51:45 UTC
Created attachment 16537 [details]
Xorg.log failure case
Comment 3 Gordon Jin 2008-05-15 04:34:24 UTC
Is ssh or keyboard still alive after the "freeze"?
Comment 4 Mathias Weyland 2008-05-15 12:44:40 UTC
(In reply to comment #3)
> Is ssh or keyboard still alive after the "freeze"?


No, the box is completely frozen, neither icmp ping, ssh, ctrl-alt-backspace nor the NumLock led are responding.
Comment 5 Hannu Johansson 2008-05-16 00:58:39 UTC
I can agree all above. I have OptiPlex 745 desktop which has the same chipset shown in mail sent by Mr Weyland.

I have 'gitted' snapshot of Intel driver 2.2.0 for X server 1.4.0.90 provided by Debian unstable package. Kernel is 2.6.24-1-686 SMP, Q965 chipset is probed correctly by the agpgart ("agpgart: Detected an Intel 965Q Chipset")

Running startx completely freezes the box assuming that kernel locks and only hardware restart is possible.

Previous combination of last versions of X and driver had some problems too. When closing X or switching back to console caused a signal lost (monitor went to a power safe mode) and only switching back to X or starting a new instance from blind console caused a signal recover to monitor. Unfortunately I have no information what were the versions of that, I'm trying to resolve it out.

If you need any debugging information about this case I'm happy to help.
Comment 6 Florian Steinel 2008-05-17 10:03:02 UTC
Created attachment 16603 [details]
bisect  xf86-video-intel-2.3.0 and xf86-video-intel-2.3.1

I run git bisect from xf86-video-intel-2.3.0 to xf86-video-intel-2.3.1.

see also:
http://article.gmane.org/gmane.comp.freedesktop.xorg/28655

Regards,
Florian
Comment 7 Gordon Jin 2008-05-17 18:50:56 UTC
So it's caused by below commit:

author	Eric Anholt <eric@anholt.net>
	 Wed, 7 May 2008 01:48:20 +0000 (18:48 -0700)
committer	Zhenyu Wang <zhenyu.z.wang@intel.com>
	 Wed, 7 May 2008 03:11:46 +0000 (11:11 +0800)

Bug #15807: Fix use of the ring while VT-switched, hit by fast user switching.

The fix for flushing at blockhandler with no DRI on 965 was broken and would
try to flush the chip even when the driver wasn't in control of the VT.
Hilarity ensued.
Comment 8 Florian Steinel 2008-05-18 03:52:32 UTC
(In reply to comment #7)
> So it's caused by below commit:
Sorry, wrong bisect. (I missed one reboot between warm-reboot).
I'm now running with version 2.3.1 minus:
commit ab0aa8e16c6bec2785006cee09dc1ae93a1988da
Author: Jesse Barnes <jbarnes@nietzche.virtuousgeek.org>
Date:   Tue May 6 14:38:48 2008 -0700

    Add FIFO watermark regs to register dumper
    (cherry picked from commit 0c00a638ef57aa9d6a3047176b0bfad733f781f0)

:040000 040000 7326c22e5a824f0fcf370736d6c1c0f1edad7a5c 7d97a1e145b609b297747b44954013c6fa3417e7 M	src

On:
00:02.0 VGA compatible controller: Intel Corporation 82G35 Express Integrated Graphics Controller (rev 03)
Comment 9 Gordon Jin 2008-05-18 19:48:23 UTC
so reassign back to Jesse.
Comment 10 Mathias Weyland 2008-05-19 11:39:44 UTC
I ran the same bisect and can confirm:

ab0aa8e16c6bec2785006cee09dc1ae93a1988da is first bad commit
commit ab0aa8e16c6bec2785006cee09dc1ae93a1988da
Author: Jesse Barnes <jbarnes@nietzche.virtuousgeek.org>
Date:   Tue May 6 14:38:48 2008 -0700

    Add FIFO watermark regs to register dumper
    (cherry picked from commit 0c00a638ef57aa9d6a3047176b0bfad733f781f0)

:040000 040000 7326c22e5a824f0fcf370736d6c1c0f1edad7a5c 7d97a1e145b609b297747b44954013c6fa3417e7 M	src
Comment 11 Jesse Barnes 2008-05-19 12:39:00 UTC
Thanks a lot for bisecting, I know that can be a pain.  We should probably just revert that commit.  Unfortunately I can't do that until my FDO account starts working again...
Comment 12 Wang Zhenyu 2008-05-19 18:00:05 UTC
I've pushed the revert patch. Close this one.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.