Bug 16105 - initial group width n >= 2 results in broken map
initial group width n >= 2 results in broken map
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/Input/Core
unspecified
Other All
: medium normal
Assigned To: Daniel Stone
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 05:52 UTC by Vincent Untz
Modified: 2011-04-14 14:22 UTC (History)
8 users (show)

See Also:


Attachments
"xkbcomp -xkb :0 -" output before g-s-d starts (51.95 KB, text/plain)
2008-05-26 05:59 UTC, Vincent Untz
no flags Details
"xkbcomp -xkb :0 -" output after g-s-d is started (68.36 KB, text/plain)
2008-05-26 06:00 UTC, Vincent Untz
no flags Details
"xkbcomp -xkb :0 -" output with autologin (45.54 KB, text/plain)
2008-05-26 06:16 UTC, Vincent Untz
no flags Details
"xkbcomp -xkb :0 -" output with normal login (68.36 KB, text/plain)
2008-05-26 06:17 UTC, Vincent Untz
no flags Details
xorg.conf (5.37 KB, text/plain)
2008-07-25 04:30 UTC, Vincent Untz
no flags Details
Xorg.0.log (compressed because too big, sorry) (19.09 KB, application/x-gzip)
2008-07-25 04:32 UTC, Vincent Untz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Untz 2008-05-26 05:52:45 UTC
With some configuration, a login in GNOME can result in a broken keymap. Note that it only happens when there's no "interaction" with X before gnome-settings-daemon starts to play with XKB (where interaction means keyboard or mouse button usage).

Long discussion happening here: https://bugzilla.novell.com/show_bug.cgi?id=369263
Comment 1 Vincent Untz 2008-05-26 05:59:40 UTC
Created attachment 16737 [details]
"xkbcomp -xkb :0 -" output before g-s-d starts
Comment 2 Vincent Untz 2008-05-26 06:00:06 UTC
Created attachment 16738 [details]
"xkbcomp -xkb :0 -" output after g-s-d is started
Comment 3 Vincent Untz 2008-05-26 06:02:00 UTC
To easily reproduce the bug:
 + apply the gconf dump from https://bugzilla.novell.com/attachment.cgi?id=212640 (with gconftool-2 --load)
 + enable GDM or KDM autologin (or timed login)

The latter is important since if you don't do that, then you will use your keyboard to enter the login/password and the bug does not occur anymore.

I can help debugging this, of course.
Comment 4 Vincent Untz 2008-05-26 06:16:54 UTC
Created attachment 16739 [details]
"xkbcomp -xkb :0 -" output with autologin

Ok, forget about attachment 16738 [details]. Don't know why, but it looks broken. Here's the real broken version :-)
Comment 5 Vincent Untz 2008-05-26 06:17:33 UTC
Created attachment 16740 [details]
"xkbcomp -xkb :0 -" output with normal login

And here's the xkbcomp dump when I don't use autologin.
Comment 6 Vincent Untz 2008-05-26 06:19:56 UTC
All the previous dumps were done with the default group being 1. If I make the default group 0, then I get the same dumps, it seems.

(also note that I'm not using the exact same gconf config as in the novell bug -- I'm having 4 groups)
Comment 7 Antonio Zugaldia 2008-06-30 14:54:20 UTC
Related: http://bugzilla.gnome.org/show_bug.cgi?id=532938

Any information you need?
Comment 8 Peter Hutterer 2008-07-23 23:24:50 UTC
Vincent: 

can I have a look at your xorg.conf and log file please? At the moment it
looks like gnome sets azerty, but your keyboard inits with querty. We need to
find out why that is so.
Comment 9 Vincent Untz 2008-07-25 04:30:17 UTC
(In reply to comment #8)
> Vincent: 
> 
> can I have a look at your xorg.conf and log file please? At the moment it
> looks like gnome sets azerty, but your keyboard inits with querty. We need to
> find out why that is so.

So my system changed quite a lot since last time. Anyway, I will attach the files. Note that my X was probably never configured to be qwerty by default.
Comment 10 Vincent Untz 2008-07-25 04:30:47 UTC
Created attachment 17886 [details]
xorg.conf
Comment 11 Vincent Untz 2008-07-25 04:32:36 UTC
Created attachment 17887 [details]
Xorg.0.log (compressed because too big, sorry)
Comment 12 Peter Hutterer 2008-07-28 23:01:56 UTC
Probably the same reason as 16364, don't have a solution yet though.
Comment 13 Peter Hutterer 2008-10-22 00:14:41 UTC
Could have been fixed with the commits leading up to c06e27b2f6fd9f7b9f827623a48876a225264132. We saw similar issues in Fedora and they are all fixed now (by the above commits).

And the hack as proposed in Bug 16364 of course.
Comment 14 Daniel Stone 2011-04-14 12:28:40 UTC
Vincent, are you still seeing this? I'll try to find some time to check it myself soon.
Comment 15 Vincent Untz 2011-04-14 12:53:20 UTC
(In reply to comment #14)
> Vincent, are you still seeing this? 

No, I haven't seen this in ages.
Comment 16 Daniel Stone 2011-04-14 14:22:31 UTC
happy days! \o/