Bug 162 - configure crashes at xdmcp
Summary: configure crashes at xdmcp
Status: CLOSED NOTABUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-14 19:11 UTC by Kyle Aleshire
Modified: 2011-10-15 17:21 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Kyle Aleshire 2003-12-14 19:11:29 UTC
Hi,
Obtained xserver source via cvs, ran autogen.sh, then configure. ./configure
stops at:
...
checking for linux/h3600_ts.h... no
checking tslib.h usability... no
checking tslib.h presence... no
checking for tslib.h... no
./configure: line 21490: syntax error near unexpected token `XDMCP,'
./configure: line 21490: `PKG_CHECK_MODULES(XDMCP, xdmcp, have_libxdmcp="yes",
have_libxdmcp="no")'
kylea@linux:~/xserver>
Comment 1 Ted Kaminski 2004-02-22 14:43:37 UTC
solved this problem with "Dave2" on irc recently.

His pkg-config install was "broken," he didn't have a /usr/share/aclocal/pkg.m4
which defines the PKG_CHECK_MODULES macro. The solution is to reinstall pkg-config.

You appear to have the same problem, since the PKG_CHECK_MODULES line is being
passed on into the final ./configure script, which causes the interpreting shell
to freak out accordingly. It should be substituted by autoconf.

So, reinstall pkg-config, preferably the recent version.

(Does somebody maintain this bugzilla? should I close this? or more
interestingly, CAN I close this?)
Comment 2 Stéphane Loeuillet 2004-07-26 06:36:38 UTC
closing this one as asked by latest comment


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.