Bug 16347 - Display messed up on X1200 (regression between 2008-04-29 and 2008-06-05)
Summary: Display messed up on X1200 (regression between 2008-04-29 and 2008-06-05)
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/radeonhd (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Egbert Eich
QA Contact: Xorg Project Team
URL: https://bugzilla.redhat.com/show_bug....
Depends on:
Reported: 2008-06-14 02:16 UTC by Hans Ulrich Niedermann
Modified: 2008-07-13 11:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Hans Ulrich Niedermann 2008-06-14 02:16:40 UTC
I have to bring this Fedora 9 bug here:

The reporter has an X1200 which worked fine with 45fdec79, but 26ccf117 and ad59f09e do something strange with the memory setup ("Splitting WC range", "Failed to set up write-combining range") and he ends up with a scrambled screen.


Xorg.0.log diffs:

Software versions in question:
  45fdec79: xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git
  26ccf117: xorg-x11-drv-radeonhd-1.2.1-2.20080605git
  ad59f09e: xorg-x11-drv-radeonhd-1.2.1-2.20080613git

I could ask the reporter to git-bisect, but perhaps the experts here know at once. No hurry though, reporter says he is going to be away for 1.5 weeks.
Comment 1 Hans Ulrich Niedermann 2008-06-19 01:57:26 UTC
New report, similar problem, different hardware (amd780g/HD 3200):

Comment 2 Egbert Eich 2008-06-19 10:54:21 UTC
There have been some changes to the mapping code recently. It could be that this problem has been taken care of. If not please provide a new log (verbose 7).
You also may want to try the following option:
Option  "UnverifiedFeatures" "No"
Comment 3 Hans Ulrich Niedermann 2008-06-19 11:59:47 UTC
Well, https://bugzilla.redhat.com/show_bug.cgi?id=452050 suggests more that the very changes you are talking of broke it for 780?

1f65f354 is reported to be broken, and ad59f09e to work for the 780.
Comment 4 Hans Ulrich Niedermann 2008-06-19 15:43:14 UTC
The reporter with the 780
  ( https://bugzilla.redhat.com/show_bug.cgi?id=452050 )
reports that
  Option  "UnverifiedFeatures" "No"
fixes his issues.
Comment 5 Egbert Eich 2008-06-22 00:20:39 UTC
OK, I see the problem. Fix will be in shortly.
Comment 6 Egbert Eich 2008-06-22 07:23:43 UTC
A sanity check to avoid this situation has been added to git.
Ndim, maybe you can create new Fedora packages for testing. Thanks!
Reassigning to you, please assign back to me or close depending on the test results.
Comment 7 Hans Ulrich Niedermann 2008-06-23 11:38:43 UTC
Mostly, but not completely solved, I guess.

Tested with 1eff3e78 aka xorg-x11-drv-radeonhd-1.2.1-3.2.20080622git.fc9, both with and without UnverifiedFeatures:

Comment 8 Hans Ulrich Niedermann 2008-06-24 10:11:41 UTC
The X1200 guy reports a completely white screen with 1eff3e78:


His Xorg.0.log diff has two insteresting parts:


-(II) RADEONHD(0): Mapped IO at 0xb7f20000 (size 0x00010000)
+(II) RADEONHD(0): Mapped IO at 0xb7ffe000 (size 0x00010000)

Uhm... a non-aligned address? That does look fishy.

-(II) RADEONHD(0): Mapped IO at 0xb7f20000 (size 0x00010000)
-(II) RADEONHD(0): Using 3883 scanlines of offscreen memory
+(II) RADEONHD(0): Mapped IO at 0xb7ffe000 (size 0x00010000)
+(II) RADEONHD(0): IPG sideport memory not present.
+(WW) RADEONHD(0): IGP memory base 0x08c69c90 seems to be bogus.
+(==) RADEONHD(0): Not Mapping IGP memory
+(II) RADEONHD(0): Mapped FB at 0xa7fed000 (size 0x10000000)
+(II) RADEONHD(0): Using 6511 scanlines of offscreen memory

Hmm. Is that IGP stuff relevant?
Comment 9 Hans Ulrich Niedermann 2008-07-13 11:27:11 UTC
The X1200 guy reports that the Fedora package built from commit c2139d8c works for hime, so I'll close this bug.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.