Bug 16359 - When application crashes, automatically download debug symbol package
Summary: When application crashes, automatically download debug symbol package
Status: RESOLVED NOTOURBUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium enhancement
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-15 05:50 UTC by Chris Sherlock
Modified: 2011-03-11 13:55 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Sherlock 2008-06-15 05:50:17 UTC
When an application crashes, most people don't have their distros debug symbol package installed. This makes the stacktrace less than useful. 

However, given that PackageKit seems to have the ability to know what package the app is part of, then the crash reporting software could ask PackageKit to find out what symbol package is available for the software, then PackageKit could download and install it after being prompted, then the software provide a proper stacktrace with symbols. 

This would help alleviate the many, many bug reports without any symbols. I'd imagine it would certainly help the app developers out!
Comment 1 Richard Hughes 2008-06-16 06:33:18 UTC
Yes, although I don't think this should be part of PackageKit - I think the application just needs to /use/ PackageKit to install the correct packages. I think that bug-buddy really needs to be patched to use PackageKit rather than make any modifications to PK itself. Could you open a bug against bug-buddy and see how receptive they are there? Thanks.
Comment 2 Chris Sherlock 2008-06-19 06:36:15 UTC
No probs. I've logged a bug on Gnome against bug-buddy. Well, not a bug but a feature request. 

http://bugzilla.gnome.org/show_bug.cgi?id=539128
Comment 3 Jean-François Fortin Tam 2011-03-11 13:55:31 UTC
See https://bugzilla.gnome.org/show_bug.cgi?id=331004


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.