Bug 166 - fc-cache doesn't remove entries for font files that no longer exist
Summary: fc-cache doesn't remove entries for font files that no longer exist
Status: RESOLVED FIXED
Alias: None
Product: fontconfig
Classification: Unclassified
Component: fc-cache (show other bugs)
Version: 2_1
Hardware: All All
: high major
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-05 09:41 UTC by Jungshik Shin
Modified: 2004-12-04 00:53 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Jungshik Shin 2004-01-05 09:41:06 UTC
I'm reporting the bug originally reported at 

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=111973
<quote from the RH bugzilla>
Description of problem:  When font files are renamed, but the exact
same list of fonts exists in the directory as did before, running
fc-cache in the directory where the renaming occurred doesn't cause
the old names for the fonts to be removed from fonts.cache-1.  (The
conditions for causing the bug may be more general than that, but the
entries are removed if one of the fonts is then deleted and fc-cache
is rerun.)
</quote>

This also leads Mozilla to die (see
http://bugzilla.mozilla.org/show_bug.cgi?id=183729)
Comment 1 Keith Packard 2004-12-04 19:53:51 UTC
I can't reproduce this with current CVS; I'm assuming it's been fixed.  Please
reopen with another test case if it's still broken.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.