Bug 16805 - When exiting quake3-based games cursor stays on the screen
When exiting quake3-based games cursor stays on the screen
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300
git
Other All
: medium normal
Assigned To: Peter Hutterer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-22 09:32 UTC by Mikko C.
Modified: 2009-08-24 12:30 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Cursor area after exiting quake3 based games (116.27 KB, image/png)
2008-07-22 09:32 UTC, Mikko C.
Details
0001-xfree86-don-t-render-SW-cursors-for-devices-attache.patch (1.40 KB, patch)
2008-11-30 23:04 UTC, Peter Hutterer
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mikko C. 2008-07-22 09:32:31 UTC
Created attachment 17824 [details]
Cursor area after exiting quake3 based games

I have everything from git (mesa, drm, xserver, xf86-video-ati, etc)

This happens when I exit tremulous or enemy territory (both quake3 based games).

An area around the cursor stays painted on the screen, in addition to the moving cursor.

With "Desktop Effects" enabled the area is black, while it's transparent (only the cursor is showed) if I disable them, but in both cases the cursor is present.

Note that in the screenshot you can't see the cursor in the middle of the black area, but I can :)
Comment 1 Tobias Jakobi 2008-07-23 02:23:33 UTC
Hi there,

I reported a similar (or the same?) problem to Peter Hutterer on the fdo mailing list. Don't know if he already looked into this.
Since I only have one quake3-based game on my system (and this is Q3 arena) I only experienced it there.

You maybe wanna add Peter to CC.

Greets,
Tobias
Comment 2 Mikko C. 2008-07-23 04:52:23 UTC
if you know his email address, can you add him? :)
Comment 3 Tobias Jakobi 2008-07-23 07:32:58 UTC
Sure, I added him.
Comment 4 Mikko C. 2008-09-13 03:51:39 UTC
It seems this bug is gone after upgrading to xorg-server 1.5.0
I'll reopen it if I notice again.
Comment 5 Tobias Jakobi 2008-09-13 11:03:06 UTC
You've got it wrong.

xorg-server-1.5.0 was not packaged from the git master branch. All the new input stuff like XI2 and MPX is not in xorg-server-1.5.0. That's the reason why you don't see the bug anymore.
Comment 6 Peter Hutterer 2008-10-08 21:05:01 UTC
I finally got to download ET, but I can't really run it. It seems to choose monitor sync ranges that my monitor cannot do. 
In addition to that, when I ctrl+c the game, the server waits forever in drmGetLock (about 30% of the time I kill it).
So no progress here, until I can actually run anything and reproduce the bug.
Comment 7 Tobias Jakobi 2008-10-09 05:21:41 UTC
Use ioquake3 plus the quake3 demo gamedata.

Fetch ioquake3 from icculus and the gamedata here:
ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3ademo-1.11-6.x86.gz.sh
Comment 8 Peter Hutterer 2008-11-30 23:04:20 UTC
Created attachment 20708 [details] [review]
0001-xfree86-don-t-render-SW-cursors-for-devices-attache.patch

This patch fixes the issue. Can you please confirm this?
Comment 9 Eric Anholt 2008-12-02 13:29:27 UTC
Pushed the fix since it worked for me and I was rebasing it around my trees anyway.

Author: Peter Hutterer <peter.hutterer@redhat.com>
Date:   Mon Dec 1 16:57:06 2008 +1000

    xfree86: don't render SW cursors for devices attached to VCP (#16805)

Comment 10 ajax at nwnk dot net 2009-08-24 12:30:39 UTC
Mass version move, cvs -> git