Bug 16880 - [945] low performance when playing ut2004
[945] low performance when playing ut2004
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
7.0.3
x86 (IA32) Linux (All)
: medium normal
Assigned To: haihao
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-28 19:08 UTC by lin, jiewen
Modified: 2008-10-27 23:15 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-07-28 19:08:56 UTC
System Environment:
--------------------------

--Platform: 945
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: xf86-video-intel-2.4branch    
             f3b72c59e5000bcdb07cbdf080e09c55b9826eff
--3D driver:  mesa-7.0-branch 97eb33529ae2f96220eec5238d8d0e9a07ce91d5
--DRM: shipped with kernel patch-2.6.26-rc9    
--Xserver: xserver-1.4branch  c3a7903f6a6a27e53ba0372408e0c5a68c608e86
--Kernel:2.6.26-rc5
--Display connector:

Bug detailed description:
--------------------------
when playing the game , the animation is slow and moving lag slowly.

Reproduce steps:
----------------
1. xinit &
2. ut2004


Current result:
----------------
low performance

Expected result:
normal
----------------
Comment 1 lin, jiewen 2008-07-28 19:18:41 UTC
This issue also exits when playing  doom3-demo.
Comment 2 lin, jiewen 2008-10-27 22:10:31 UTC
With the current mastet package , it works well.
Comment 3 lin, jiewen 2008-10-27 23:15:42 UTC
This issue has gone agaisnt following configuration:
Libdrm: (master)1d930fc75b99a89fc77d35d8f95f2877cfd5d7f0
Mesa:   (master)2a877411dbe35abdd8c15fb4821d9232619d89cc
Xf86_video_intel:       (master)87ea531c5dc5b39809395b277c330854aaaaf019
Xserver:        (master)102c4dac7c521941f52652152b1660cd7f559d56
GEM_kernel:       (drm-intel-next)af1f46ebc03f4eab533e7a695d836ad9f255bf49