Bug 169 - xcompmgr won't link
Summary: xcompmgr won't link
Status: CLOSED WORKSFORME
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xcompmgr (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high critical
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-16 01:50 UTC by Anthony Kepler
Modified: 2011-10-15 17:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Anthony Kepler 2004-01-16 01:50:28 UTC
when attempting to build xcompmgr, I get the following:

root:/home/perlmonkee/download/xserver/xcompmgr# make
cc -o xcompmgr -O -g xcompmgr.c `pkg-config --cflags --libs xcomposite xfixes
xdamage xrender` -lm
/opt/fdo/lib/libX11.a(ConnDis.o): In function `GetAuthorization':
/home/perlmonkee/download/xserver/X11/src/ConnDis.c:1039: undefined reference to
`XauGetBestAuthByAddr'
/home/perlmonkee/download/xserver/X11/src/ConnDis.c:1196: undefined reference to
`XauDisposeAuth'
collect2: ld returned 1 exit status
make: *** [xcompmgr] Error 1
Comment 1 Anthony Kepler 2004-01-16 01:55:48 UTC
wow, it's amazing how if you stop and think for one brief shining moment, you
figure things out.  Adding xau to the list of libs to link xcompmgr against sets
things straight.
so erm uhh... I knew it all along, I was just telling *you*... thats right... right.
Comment 2 Adam Jackson 2004-09-03 19:50:08 UTC
out of curiosity, is this still an issue with current CVS?  it looks autotooled
now, and my make output looks nothing like that.
Comment 3 Adam Jackson 2004-09-14 11:40:25 UTC
marking as worksforme, please reopen if this continues to be an issue for you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.