Bug 170 - libXt not linked with libSM
Summary: libXt not linked with libSM
Status: CLOSED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xlib (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Jim Gettys
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-17 04:01 UTC by Carlos Romero
Modified: 2011-10-15 17:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
include ObjectP.h Shell.h and Xalloca.h to build in a clean environment (30.98 KB, patch)
2004-02-23 20:41 UTC, Carlos Romero
no flags Details | Splinter Review

Description Carlos Romero 2004-01-17 04:01:16 UTC
--- configure.ac.orig   2004-01-17 04:48:19.000000000 -0500
+++ configure.ac        2004-01-17 06:37:07.559489160 -0500
@@ -77,6 +77,10 @@
        fi
 fi
  
+PKG_CHECK_MODULES(SM, sm)
+AC_SUBST(SM_CFLAGS)
+AC_SUBST(SM_LIBS)
+
 # Check render configuration, strip extra digits from package version to
 # find the required protocol version
--- Makefile.am.orig    2004-01-17 04:48:19.000000000 -0500
+++ Makefile.am 2004-01-17 06:38:16.788964680 -0500
@@ -23,7 +23,7 @@
  
 SUBDIRS = include util
  
-AM_CFLAGS = $(RENDER_CFLAGS) $(X_CFLAGS) -I$(top_srcdir)/include/X11
+AM_CFLAGS = $(RENDER_CFLAGS) $(X_CFLAGS) $(SM_CFLAGS) -I$(top_srcdir)/include/X11
  
 lib_LTLIBRARIES = libXt.la
  
@@ -105,7 +105,7 @@
        Xtos.h \
        sharedlib.c
  
-libXt_la_LIBADD = @X_LIBS@
+libXt_la_LIBADD = @X_LIBS@ @SM_LIBS@
  
 libXt_la_LDFLAGS = -version-info 6:1:0
Comment 1 Carlos Romero 2004-02-23 20:41:28 UTC
Created attachment 105 [details] [review]
include ObjectP.h Shell.h and Xalloca.h to build in a clean environment
Comment 2 Carlos Romero 2004-02-23 20:43:00 UTC
ignore patch above, wrong bug


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.