Bug 17058 - Error updating system after enabled F9 testing repositories
Summary: Error updating system after enabled F9 testing repositories
Status: RESOLVED DUPLICATE of bug 16942
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-10 08:49 UTC by Carlos Eduardo Pedroza Santiviago
Modified: 2008-09-26 08:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Eduardo Pedroza Santiviago 2008-08-10 08:49:15 UTC
I just did a F9 full installation, and after the update, and reboot, i enabled the testing repositories. PackageKit started retrieving the updates, and got this error:

Error Type: <type 'exceptions.TypeError'>
Error Value: object of type 'instancemethod' has no len()
  File : /usr/share/PackageKit/helpers/yum/update-system.py , line 18, in <module>
    backend.update_system()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 850, in update_system
    self._runYumTransaction()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1151, in _runYumTransaction
    hex_fingerprint = "80740e5" * len(fingerprint) 152096176ple(map(ord, fingerprint))

PackageKit was trying to update the package kernel-2.6.25.14-109.fc9 (i686).
Comment 1 Richard Hughes 2008-08-11 00:15:14 UTC
Shuld be fixed here: https://admin.fedoraproject.org/updates/F9/FEDORA-2008-7001
Comment 2 Richard Hughes 2008-09-26 08:11:40 UTC

*** This bug has been marked as a duplicate of bug 16942 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.