Bug 17083 - Error Message while installing any package.
Summary: Error Message while installing any package.
Status: RESOLVED DUPLICATE of bug 16942
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-11 12:12 UTC by Yasir Niaz
Modified: 2008-09-26 08:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
screenshot of error message (228.03 KB, image/png)
2008-08-11 12:14 UTC, Yasir Niaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yasir Niaz 2008-08-11 12:12:58 UTC
Error Type: <type 'exceptions.TypeError'>
Error Value: object of type 'instancemethod' has no len()
  File : /usr/share/PackageKit/helpers/yum/install-packages.py , line 19, in <module>
    backend.install_packages(packages)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 226, in wrapper
    func(*args,**kwargs)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 949, in install_packages
    self._runYumTransaction()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1151, in _runYumTransaction
    hex_fingerprint = "80740e5" * len(fingerprint) 164159872ple(map(ord, fingerprint))
Comment 1 Yasir Niaz 2008-08-11 12:14:22 UTC
Created attachment 18222 [details]
screenshot of error message
Comment 2 Richard Hughes 2008-08-12 01:54:06 UTC
Fixed in the latest PackageKit in Fedora. Can you try "yum update PackageKit" please, and then try again.
Comment 3 Richard Hughes 2008-09-26 08:11:41 UTC

*** This bug has been marked as a duplicate of bug 16942 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.