Bug 1722 - Fix keyboard behaviour on FreeBSD/sparc64
Summary: Fix keyboard behaviour on FreeBSD/sparc64
Status: RESOLVED DUPLICATE of bug 2587
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: git
Hardware: SPARC FreeBSD
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-27 10:20 UTC by Dejan Lesjak
Modified: 2005-07-12 19:28 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Fix for FreeBSD/sparc64 by Marius Strobl (2.07 KB, patch)
2004-10-27 10:21 UTC, Dejan Lesjak
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Dejan Lesjak 2004-10-27 10:20:29 UTC
The problem is that on FreeBSD/sparc64 keys are off by one as is explained here:
http://lists.freebsd.org/pipermail/freebsd-sparc64/2004-August/002036.html with 
some further discussion here:
http://lists.freebsd.org/pipermail/freebsd-sparc64/2004-September/002091.html
Marius Strobl (marius at alchemy.franken.de) submitted a patch that corrects 
this (the same workaround is needed as on linux) and is already in FreeBSD Xorg 
ports. Furthermore he adds that "#ifndef __sparc64__ added in 3.156 [in XFree86 
CVS] can be removed again." Both changes included in upcoming patch.
Comment 1 Dejan Lesjak 2004-10-27 10:21:16 UTC
Created attachment 1183 [details] [review]
Fix for FreeBSD/sparc64 by Marius Strobl
Comment 2 Alan Hourihane 2005-07-14 05:28:14 UTC

*** This bug has been marked as a duplicate of 2587 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.