Bug 17735 - XPutImage performance regression with xlib/xcb
Summary: XPutImage performance regression with xlib/xcb
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xlib (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: xcb mailing list dummy
QA Contact: Xorg Project Team
URL:
Whiteboard: 2011BRB_Reviewed
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-23 05:26 UTC by Clemens Eisserer
Modified: 2011-10-05 10:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
test-case (7.84 KB, text/plain)
2008-09-23 05:26 UTC, Clemens Eisserer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2008-09-23 05:26:54 UTC
Created attachment 19129 [details]
test-case

All the test-case attached does is uploading 32x32x8 bit images (1kb) and do a composite operation with the data used as mask.


I was testing the advantage of using SHM and using SHM is over 2x faster using the XCB based Xlib than XPutImage.

Here are my findings:
Xlib/Put:        80ms
Xlib/ShmPut:     75ms
Xcb-Xlib/Put:   180ms (!)
Xcb-Xlib/ShmPut  80ms 

I was using the xlib-binaries distributed by Fedora, Xlib was Fedora7, and Xcb-Xlib was on Fedora9, so please take the results with a grain of salt.
I also don't know wether Fedora maybe hand-tuned the Xlib-Buffer size in Fedora7.
Comment 1 Clemens Eisserer 2009-03-16 17:22:00 UTC
as far as I can remember, the difference was mostly caused by the different buffer sizes. I'll test it soon so see if there's still a difference...
Comment 2 Julien Cristau 2009-08-02 08:13:01 UTC
(In reply to comment #1)
> as far as I can remember, the difference was mostly caused by the different
> buffer sizes. I'll test it soon so see if there's still a difference...
> 
any news?
Comment 3 Clemens Eisserer 2011-10-05 02:55:34 UTC
re-tested and there is no regression compared to "classic" xlib.
So this bug is fixed - Thanks :)
Comment 4 Julien Cristau 2011-10-05 10:47:46 UTC
Closing as fixed.


bug/show.html.tmpl processed on Mar 29, 2017 at 11:10:36.
(provided by the Example extension).