Bug 17801 - xorg-server-1.5.0 doesn't seem to work fine on alpha
Summary: xorg-server-1.5.0 doesn't seem to work fine on alpha
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 7.4 (2008.09)
Hardware: Alpha Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-26 13:27 UTC by Raúl Porcel
Modified: 2009-08-05 20:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
MGA driver xorg-server 1.5 log (6.33 KB, text/plain)
2008-09-26 13:28 UTC, Raúl Porcel
no flags Details
glint driver xorg-server 1.5 log (1.41 KB, text/plain)
2008-09-26 13:30 UTC, Raúl Porcel
no flags Details
glint driver xorg-server 1.3 log (11.15 KB, text/plain)
2008-09-26 13:34 UTC, Raúl Porcel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl Porcel 2008-09-26 13:27:16 UTC
Hi,

xorg-server-1.5.0 is not able to detect a PCI glint card, and it gives "unable to detect video ram" with a PCI MGA card...

Will attach the logs of working xorg-server-1.3.0.0 and non-working xorg-server-1.5.0 with both MGA and glint.

I'm not sure if its related to bug 11730. And i'm not sure if its related to bug 17743, since it seems to be the same symptoms, although in this case the both cards are PCI.

Thanks,
Comment 1 Raúl Porcel 2008-09-26 13:28:13 UTC
Created attachment 19248 [details]
MGA driver xorg-server 1.5 log
Comment 2 Raúl Porcel 2008-09-26 13:30:34 UTC
Created attachment 19249 [details]
glint driver xorg-server 1.5 log
Comment 3 Raúl Porcel 2008-09-26 13:34:26 UTC
Created attachment 19250 [details]
glint driver xorg-server 1.3 log
Comment 4 Julien Cristau 2008-09-26 15:01:04 UTC
> --- Comment #1 from Raúl Porcel <armin76@gentoo.org>  2008-09-26 13:28:13 PST ---
> Created an attachment (id=19248)
>  --> (http://bugs.freedesktop.org/attachment.cgi?id=19248)
> MGA driver xorg-server 1.5 log
> 
The kernel needs to provide the pci-sysfs resource files
(/sys/bus/pci/devices/*/resource*) so X (via libpciaccess) can map the
BAR.
See http://bugzilla.kernel.org/show_bug.cgi?id=10893
Comment 5 Matt Turner 2009-08-05 20:49:21 UTC
Marking as NOTOURBUG, as the problem is in the kernel (Fixed as of 2.6.29 IIRC).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.