Bug 1794 - [810] Xorg lockup with error "Active ring not flushed"
[810] Xorg lockup with error "Active ring not flushed"
Product: xorg
Classification: Unclassified
Component: Driver/intel
x86 (IA32) Linux (All)
: medium blocker
Assigned To: Default DRI bug account
Xorg Project Team
Depends on:
  Show dependency treegraph
Reported: 2004-11-08 03:54 UTC by Pongten
Modified: 2012-07-22 16:47 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:

Xorg log with i810 support option set (27.74 KB, text/plain)
2004-11-08 03:56 UTC, Pongten
no flags Details
Xorg log with i810 support option unset (25.54 KB, text/plain)
2004-11-08 03:56 UTC, Pongten
no flags Details
Config file of the kernel (28.01 KB, text/plain)
2004-11-08 15:35 UTC, Pongten
no flags Details
CONFIG_FB_I810 turned off, colordepth : 24-bit (25.54 KB, text/plain)
2004-11-09 01:11 UTC, Pongten
no flags Details
CONFIG_DRM_I810=m, module not loaded, colordepth : 24-bit (25.54 KB, text/plain)
2004-11-09 01:21 UTC, Pongten
no flags Details
CONFIG_DRM_I810 off, colordepth : 24-bit (25.54 KB, text/plain)
2004-11-11 14:41 UTC, Pongten
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pongten 2004-11-08 03:54:46 UTC
Xorg is working fine with kernel 2.6.8 but crashes with 2.6.9.
If option i810 support (EXPERIMENTAL) (in device drivers->graphics) is set, 
error is : Serveur lockup
If not, error is "Active ring not flushed"

Xorg version : 6.8.0

Reproducible: Always
Steps to Reproduce:

Actual Results:  
X crashes

Expected Results:  
X started ;)
Comment 1 Pongten 2004-11-08 03:56:09 UTC
Created attachment 1239 [details]
Xorg log with i810 support option set
Comment 2 Pongten 2004-11-08 03:56:23 UTC
Created attachment 1240 [details]
Xorg log with i810 support option unset
Comment 3 Dave Airlie 2004-11-08 14:55:27 UTC
This looks to me an i810 bug only and I cannot make it happen on my i815 setup
which isn't helping me debug it,

It looks to be an issue only with 24-bit i810 support where there is not DRI
support (hardware only support 16-bit acceleration),

Quite why 2.6.9 would display any different behaviour than 2.6.8 is mystifying
me as the DRM device is never opened in this case, so AGP is the only think I
can think to point at.

Do you have i810 framebuffer support built into the kernel?

attach your .config and both those log files look to me like X crashes....
Comment 4 Pongten 2004-11-08 15:35:27 UTC
Created attachment 1244 [details]
Config file of the kernel
Comment 5 Pongten 2004-11-08 15:44:40 UTC
I confirm : it's a 24-bit support problem.  With 16-bit it works perfectly with 
2.6.9 ;-)
Comment 6 Dave Airlie 2004-11-08 17:01:11 UTC
Can you recompile your kernel with CONFIG_FB_I810 turned off? and try again with

if that has no affect, can you try making CONFIG_DRM_I810=m and not loading the
module with 24-bit.... 

Comment 7 Pongten 2004-11-09 01:11:50 UTC
Created attachment 1246 [details]
CONFIG_FB_I810 turned off, colordepth : 24-bit
Comment 8 Pongten 2004-11-09 01:21:26 UTC
Created attachment 1247 [details]
CONFIG_DRM_I810=m, module not loaded, colordepth : 24-bit
Comment 9 Dave Airlie 2004-11-11 00:30:59 UTC
Okay one last test if you have a chance please..

build with CONFIG_DRM_I810 turned off completely.. this could be an AGP bug...
Comment 10 Pongten 2004-11-11 14:41:35 UTC
Created attachment 1294 [details]
CONFIG_DRM_I810 off, colordepth : 24-bit
Comment 11 Karol Krizka 2004-11-22 11:36:01 UTC
I am experiencing the same problem. (http://bugs.gentoo.org/show_bug.cgi?id=72098)
But I noticed one thing, when I do startx from my root account, there is no
problem. Maybe this is a problem with permissions somewhere?
Comment 12 Donnie Berkholz 2004-11-22 14:52:27 UTC
See bug #1771 among others for more info.
Comment 13 Matthias Hopf 2004-11-26 03:21:15 UTC
Ok, I *finnally* was able to reproduce the bug over here.
It is indeed a i810 only related problem, i815 seems to run flawlessly.
However, I also get an "Active ring not flushed" with 16bit, and not with 24bit
only. It might be still the same problem, though.

I'll try something about that next week.
Comment 14 Matthias Hopf 2004-12-02 08:07:20 UTC

I give up. It seems to be that I stumbled upon some effect due to a completely
broken setup. I tried to reproduce the version of X/kernel at which the driver
freezes, and right now I'm running a SuSE 9.1 with CVS X and vanila 2.6.9 kernel
and *everything* works - 16bit w/ DRI, 24bit w/o DRI, no crash, no lockups,
nothing. And yes, this is a i810.

Just like with bug 1771 this might well be broken hardware, which is only
triggered by kernel module changes.

Sorry, but I can't do a thing about that when I cannot reproduce it.
Comment 15 Paul Pierce 2004-12-21 12:46:41 UTC
I'm seeing ring errors with gentoo kernel 2.6.8 and all gentoo releases of X
6.8.0, last gentoo X 6.7 works fine. - Paul Pierce
Comment 16 Dave Airlie 2005-02-14 00:25:33 UTC
I'm tracking an SIS bug and it only happens between 2.6.8 and 2.6.9 as well...

it seems to be caused by the address layout changes..

if someone has an original i810 maybe try running the X server using the setarch 

setarch -L i386 startx

Comment 17 Brice Goglin 2007-06-30 06:25:31 UTC
Somebody replied to Debian bug #355125 saying that this "Active ring not flushed" error still happens on i810 with kernel 2.6.18 and Intel driver 2.0. It happens once every 2 weeks or so. See the latest posts in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355125

Is the "address layout changes" still considered a good candidate for causing this error? Or does anybody have any idea how to fix it?

Comment 18 Eugeni Dodonov 2011-09-08 15:56:34 UTC
This issue is affecting a hardware component which is not being actively worked on anymore.

Moving the assignee to the dri-devel list as contact, to give this issue a better coverage.
Comment 19 Chris Wilson 2012-07-22 16:47:45 UTC
i810 is dead, xaa is gone and with it all acceleration.