Bug 18171 - [Q45 G45 gem gem-classic]mesa xdemo/glthreads get some black windows(sometimes get still cubes)
Summary: [Q45 G45 gem gem-classic]mesa xdemo/glthreads get some black windows(sometim...
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: haihao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-22 00:57 UTC by liuhaien
Modified: 2008-12-18 19:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (45.15 KB, text/plain)
2008-10-22 00:57 UTC, liuhaien
Details
xorg conf file (3.67 KB, text/plain)
2008-10-22 00:59 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-10-22 00:57:07 UTC
Created attachment 19803 [details]
xorg.0.log

System Environment:
--------------------------

--Platform: q45
--Architecture(32-bit,64-bit,compatiblity): 64-bit
--2D driver: xf86-video-intel-2.5-branch 
             0135a49ec96ca311d0673a4d924b63fe4a921e37
--3D driver: intel-2008-q3 branch 46921a5ee832a3443894dcc98e065d2f535e899d
--DRM:shipped with kernel 2.6.27stolen-mem
--libdrm: master branch  a59ea02ff839fa0801763a90beb8b232b933c746
--Xserver: 1.5.2
--Kernel: 2.6.27stolen-mem(with eric's G4x fix)

Bug detailed description:
--------------------------
startx with our q3-rc5 package ,then run mesa xdemo glthreads ,we will get some black windows,not rotating cubes.and sometimes will get still cubes.but it works fine with q3-rc4.
Reproduce steps:
----------------
1. xinit &
2. ./glthreads -n 10
Comment 1 liuhaien 2008-10-22 00:59:35 UTC
Created attachment 19804 [details]
xorg conf file
Comment 2 liuhaien 2008-10-22 01:02:07 UTC
and g45 ,gm45 and q965 are all fine.  it only happens on q45.
Comment 3 liuhaien 2008-10-28 19:16:29 UTC
same issue exits with GEM:
Mesa:           (master)2a877411dbe35abdd8c15fb4821d9232619d89cc
Xserver:                (master)102c4dac7c521941f52652152b1660cd7f559d56
Xf86_video_intel:              
(master)87ea531c5dc5b39809395b277c330854aaaaf019
libdrm:(master)e47ab7a5081e178bad385ce2e75b01474ea7aa4c
Kernel_gem:            
(drm-intel-next)43f7ccc48dd7587983cfe16de578042a7ad3a9b3
Comment 4 lin, jiewen 2008-12-07 22:59:19 UTC
With current code, G45(64bit) also has this issue, G45(32) is fine.
Comment 5 haihao 2008-12-18 18:47:09 UTC
Can't reproduce it with current code, it should be fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.