Bug 18258 - recording with wavenc generates truncated audio files
Summary: recording with wavenc generates truncated audio files
Status: RESOLVED NOTABUG
Alias: None
Product: gstreamer
Classification: Unclassified
Component: account (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Thomas Vander Stichele
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-28 00:40 UTC by Pablo Rodríguez
Modified: 2008-11-09 10:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Pablo Rodríguez 2008-10-28 00:40:45 UTC
Recording audio with to a wav file with GStreamer generates a truncated file:

$ gst-launch alsasrc ! audioconvert ! wavenc ! filesink location=test.wav

sox warns about the truncated file:

sox test.wav prueba.wav
sox wav: Premature EOF on .wav input file

But the file is fine when recording to an ogg file:

$ gst-launch alsasrc ! audioconvert ! vorbisenc ! oggmux ! filesink 
location=test.ogg

Is this a bug in wavenc or am I missing something?

Thanks for your help,


Pablo
Comment 1 Thomas Vander Stichele 2008-11-09 06:58:09 UTC
This bug tracker is for administrative requests.

Please file at http://bugzilla.gnome.org/ instead

(I think that the behaviour is correct; wavenc can't go back to the beginning of the file to rewrite the header)

Comment 2 Pablo Rodríguez 2008-11-09 10:01:45 UTC
Sorry, but I was wrong (and because of that I'm changing the resolution to NOTABUG). I'm a newbie in programming, but it was my fault.

The original question came from a Python GStreamer script that stopped the recording setting the player state to null instead of sending an EOS message to the player.

I knew that the GStreamer documentation warned about that, but I wasn't sure that this was the cause, since oggenc and lame are written fine. And I didn't know how to send an EOS event.

I asked twice in both the pyGTK and Python-es mailing lists. The only reply I received was that this might be a bug in GStreamer.

After that, trying again to combine both the GStreamer and Python GStreamer documentation, I was lucky to find the proper instruction.

Sorry for the inconveniences.


Pablo


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.