Bug 18465 - X crashes when disabling compositing in kwin
Summary: X crashes when disabling compositing in kwin
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: * Other (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-10 05:41 UTC by Gábor Lehel
Modified: 2009-09-01 01:54 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
X log (24.64 KB, text/plain)
2008-11-10 05:42 UTC, Gábor Lehel
no flags Details
backtrace of the server crash (2.06 KB, text/plain)
2008-11-14 11:13 UTC, Magnus Kessler
no flags Details
avoid calling DRIGetDrawableInfo with NULL pScreen (439 bytes, patch)
2008-11-14 11:17 UTC, Magnus Kessler
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Gábor Lehel 2008-11-10 05:41:30 UTC
KWin in KDE4 has a shortcut to toggle compositing on and off. Sometimes (not always) when I toggle compositing off with this, X crashes. Dunno if this is a bug in kwin or X, so I'm reporting it in both places. Attaching the X log. There's a not-too-useful backtrace near the end.
Comment 1 Gábor Lehel 2008-11-10 05:42:19 UTC
Created attachment 20179 [details]
X log
Comment 2 Gábor Lehel 2008-11-11 10:11:53 UTC
A workaround for this was just committed to kwin: http://bugs.kde.org/show_bug.cgi?id=174782#c1 (includes what looks like more info about the bug itself)
Comment 3 Magnus Kessler 2008-11-14 11:13:04 UTC
Created attachment 20310 [details]
backtrace of the server crash
Comment 4 Magnus Kessler 2008-11-14 11:17:48 UTC
Created attachment 20311 [details] [review]
avoid calling DRIGetDrawableInfo with NULL pScreen

This patch adds an extra check for a NULL pScreen pointer into glxdri.c getDrawableInfo(), in line with an existing check for a NULL pDraw pointer.
Comment 5 Michel Dänzer 2008-11-14 12:28:40 UTC
The patch is a hack and won't always help I'm afraid. The problem is that pDraw is a stale pointer.
Comment 6 Michel Dänzer 2009-09-01 01:54:06 UTC
This should be fixed in xserver 1.6.3.901.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.