Bug 18470 - /etc/…/conf.avail can be considered an FHS violation
Summary: /etc/…/conf.avail can be considered an FHS violation
Status: RESOLVED DUPLICATE of bug 29341
Alias: None
Product: fontconfig
Classification: Unclassified
Component: conf (show other bugs)
Version: 2.6
Hardware: Other All
: medium normal
Assignee: fontconfig-bugs
QA Contact: Behdad Esfahbod
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-10 10:40 UTC by Nicolas Mailhot
Modified: 2012-04-09 00:46 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2008-11-10 10:40:39 UTC
As explained in
http://lists.freedesktop.org/archives/fontconfig/2008-October/003030.html

conf.avail can be considered an FHS violation

Can it be moved somewhere in /usr/share?

We'd like to make font packages use the conf.d/conf.avail split in Fedora 11 but our package auditing tools do not like an /etc/fonts/conf.avail read-only directory at all, strongly hinting the current default should be changed.

And if it has to be changed we'd rather it was changed before scores of packages depend on the current default.

Fedora 11 packaging cycle will open soonish.
Comment 1 Nicolas Mailhot 2008-11-14 08:15:57 UTC
If we could have an opinion on the correct directory name that would un-block our font guideline change process started there

http://fedoraproject.org/wiki/Fonts_SIG_Fedora_11_packaging_changes
Comment 2 Akira TAGOH 2012-04-09 00:46:08 UTC

*** This bug has been marked as a duplicate of bug 29341 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.