Bug 18687 - [915GM SDVO-VGA] no display on 2 VGA on POS
[915GM SDVO-VGA] no display on 2 VGA on POS
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
x86 (IA32) Linux (All)
: medium major
Assigned To: Wang Zhenyu
Xorg Project Team
:
Depends on:
Blocks: 18858
  Show dependency treegraph
 
Reported: 2008-11-24 08:02 UTC by Lew Shih Ming
Modified: 2009-02-04 01:14 UTC (History)
10 users (show)

See Also:


Attachments
xorg.conf file configured for 2 external monitors (5.08 KB, text/plain)
2008-11-24 08:02 UTC, Lew Shih Ming
no flags Details
xrandr info when single VGA is connected (no internal display for this system) (889 bytes, text/plain)
2008-11-24 08:06 UTC, Lew Shih Ming
no flags Details
xrandr info when a 2nd VGA monitor is connected to secondary VGA output (1.23 KB, text/plain)
2008-11-24 08:10 UTC, Lew Shih Ming
no flags Details
dmesg (29.65 KB, text/plain)
2008-11-26 00:14 UTC, Lew Shih Ming
no flags Details
xorg log (34.16 KB, text/plain)
2008-11-26 00:16 UTC, Lew Shih Ming
no flags Details
xrandr --verbose (12.44 KB, text/plain)
2008-11-26 00:17 UTC, Lew Shih Ming
no flags Details
xorg log with debug mode and 2 monitors connected to VGA ports (338.40 KB, text/plain)
2008-11-27 02:03 UTC, Lew Shih Ming
no flags Details
xrandr with verbose 2 (11.26 KB, text/plain)
2008-11-27 02:06 UTC, Lew Shih Ming
no flags Details
xorg.conf with ignore option in monitor section (5.17 KB, text/plain)
2008-11-30 01:39 UTC, Lew Shih Ming
no flags Details
xorg.conf with LVDS ignored (5.14 KB, text/plain)
2008-12-01 00:37 UTC, Lew Shih Ming
no flags Details
dmesg with disabled LVDS and 2 VGA connected (33.10 KB, text/plain)
2008-12-01 18:58 UTC, Lew Shih Ming
no flags Details
xorg with disabled LVDS and 2 VGA connected (228.12 KB, text/plain)
2008-12-01 19:02 UTC, Lew Shih Ming
no flags Details
xrandr verbose with disabled LVDS and 2 VGA connected (7.40 KB, text/plain)
2008-12-01 19:04 UTC, Lew Shih Ming
no flags Details
xorg.conf (4.87 KB, text/plain)
2008-12-09 01:52 UTC, Vance
no flags Details
dmesg Jesse Patch (32.20 KB, text/plain)
2008-12-09 01:53 UTC, Vance
no flags Details
Xorg.0.log Jesse Patch (164.76 KB, text/plain)
2008-12-09 01:54 UTC, Vance
no flags Details
xrandr Jesse Patch (4.17 KB, text/plain)
2008-12-09 01:54 UTC, Vance
no flags Details
dmesg Zhenyu's Patch (32.05 KB, text/plain)
2008-12-09 01:56 UTC, Vance
no flags Details
Xorg.0.log Zhenyu's Patch (200.88 KB, text/plain)
2008-12-09 01:57 UTC, Vance
no flags Details
xrandr Zhenyu (4.17 KB, text/plain)
2008-12-09 01:57 UTC, Vance
no flags Details
Screenshot of Display with patch (363.85 KB, image/jpeg)
2008-12-10 20:15 UTC, Vance
no flags Details
Dmesg Log (31.77 KB, application/octet-stream)
2008-12-10 20:17 UTC, Vance
no flags Details
Xorg.0.log (130.66 KB, text/plain)
2008-12-10 20:18 UTC, Vance
no flags Details
Xandar --verbose (1.28 KB, application/octet-stream)
2008-12-10 20:19 UTC, Vance
no flags Details
Rom Binary (64.00 KB, application/octet-stream)
2008-12-10 20:20 UTC, Vance
no flags Details
xandr --verbose (4.13 KB, text/plain)
2008-12-10 22:23 UTC, Vance
no flags Details
Xorg.0.log (203.79 KB, text/plain)
2008-12-10 22:24 UTC, Vance
no flags Details
Dmesg (31.77 KB, text/plain)
2008-12-10 22:26 UTC, Vance
no flags Details
Xrandr (2.08 KB, text/plain)
2008-12-11 02:38 UTC, Vance
no flags Details
Xorg.0.log (169.17 KB, text/plain)
2008-12-11 02:39 UTC, Vance
no flags Details
Dmesg (30.76 KB, text/plain)
2008-12-11 02:39 UTC, Vance
no flags Details
rom.bin from old machine (64.00 KB, application/octet-stream)
2008-12-15 02:41 UTC, Lew Shih Ming
no flags Details
xorg log after patch (175.39 KB, text/plain)
2008-12-16 02:49 UTC, Lew Shih Ming
no flags Details
xorg log after jessie patch on xf86-video-intel-2.5.0 (227.20 KB, text/plain)
2008-12-18 03:07 UTC, Lew Shih Ming
no flags Details
xrandr after jessie's patch on xf86-video-intel-2.5.0 (5.71 KB, text/plain)
2008-12-18 03:11 UTC, Lew Shih Ming
no flags Details
screenshot of clone displays (120.32 KB, image/pjpeg)
2008-12-18 03:19 UTC, Lew Shih Ming
no flags Details
xorg.conf after removing Freq (4.34 KB, text/plain)
2008-12-22 02:37 UTC, Lew Shih Ming
no flags Details
xrandr --verbose after removing Freq. (5.32 KB, text/plain)
2008-12-22 02:39 UTC, Lew Shih Ming
no flags Details
xorg log using vesa (45.08 KB, application/octet-stream)
2008-12-22 03:34 UTC, Lew Shih Ming
no flags Details
xorg log after replacing reworked HW (260.50 KB, text/plain)
2009-01-12 03:45 UTC, Lew Shih Ming
no flags Details
xrandr --verbose after replaced reworked HW (6.76 KB, text/plain)
2009-01-12 03:51 UTC, Lew Shih Ming
no flags Details
xorg after sax2 -l (4.46 KB, text/plain)
2009-01-22 20:25 UTC, Lew Shih Ming
no flags Details
xrandr after sax2 -l (9.67 KB, text/plain)
2009-01-22 20:28 UTC, Lew Shih Ming
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lew Shih Ming 2008-11-24 08:02:22 UTC
Created attachment 20551 [details]
xorg.conf file configured for 2 external monitors

---Problem Description---
Both primary and secondary VGA monitor have no displays (blank screen) when both are connected to the system.

Single display with 1 VGA monitor has no display problem. The video driver used for i915GM is 'intel'.

---uname output---
2.6.27.5-2-pae #1 SMP 2008-10-16 20:35:15 +0200 i686 i686 i386 GNU/Linux

---distros---
SLED11 Beta

---Steps to Reproduce---
1) Connect 2 VGA monitors to 2 VGA output interfaces of the system.
2) Boot up the system into SLED11
Comment 1 Lew Shih Ming 2008-11-24 08:06:48 UTC
Created attachment 20552 [details]
xrandr info when single VGA is connected (no internal display for this system)
Comment 2 Lew Shih Ming 2008-11-24 08:10:01 UTC
Created attachment 20553 [details]
xrandr info when a 2nd VGA monitor is connected to secondary VGA output
Comment 3 Gordon Jin 2008-11-25 18:27:12 UTC
Why do you write xorg.conf as below:
  Option       "monitor-LVDS" "EXT"
  Option       "monitor-TV-1" "EXT"

What's your board type? So it has 2 VGA ports, and nothing to do with TV?

Please also attach Xorg log according to http://intellinuxgraphics.org/how_to_report_bug.html
Comment 4 Lew Shih Ming 2008-11-26 00:03:17 UTC
(In reply to comment #3)
> Why do you write xorg.conf as below:
>   Option       "monitor-LVDS" "EXT"
>   Option       "monitor-TV-1" "EXT"
> What's your board type? So it has 2 VGA ports, and nothing to do with TV?
> Please also attach Xorg log according to
> http://intellinuxgraphics.org/how_to_report_bug.html

I was trying to set Dual Head Mode for the system. Therefore I added these two options to test it out because there are 2 VGA ports. There is not intergated monitors but xrandr always shows that LVDS is connected.

Whenever I connect a 2nd monitor to the secondary VGA port, xrandr shows that TV-1 is connected. After checking the i915GM block diagram spec., the 2nd VGA is activiated via a TV encoder CH7317A which is also known as sDVO. Hope this piece of info helps.

More 3 files are attached.
Comment 5 Michael Fu 2008-11-26 00:09:20 UTC
what kind of device are you using? product name? model?

Comment 6 Lew Shih Ming 2008-11-26 00:14:43 UTC
Created attachment 20597 [details]
dmesg
Comment 7 Lew Shih Ming 2008-11-26 00:16:13 UTC
Created attachment 20598 [details]
xorg log
Comment 8 Lew Shih Ming 2008-11-26 00:17:17 UTC
Created attachment 20599 [details]
xrandr --verbose
Comment 9 Lew Shih Ming 2008-11-26 00:23:51 UTC
(In reply to comment #5)
> what kind of device are you using? product name? model?

It is a IBM POS terminal, a product known as SurePOS. Model is not disclosed yet as it is still in development phase. 

As for the CPU, it is Intel Celeron M processor.

thanks.
Comment 10 Michael Fu 2008-11-26 00:31:28 UTC
Oh, man, do you really need so many kind of POS machine? (bug#18495) :)

anyway, please turns ModeDebug on in your driver section of conf file and resubmit the xorg.log - this is required in http://intellinuxgraphics.org/how_to_report_bug.html...
Comment 11 Gordon Jin 2008-11-26 00:38:19 UTC
(In reply to comment #4)

> I was trying to set Dual Head Mode for the system. Therefore I added these two
> options to test it out because there are 2 VGA ports. There is not intergated
> monitors but xrandr always shows that LVDS is connected.

If you want cloned screen on 2 VGA monitors (as what I understand by Dual
Head), you don't need set specific options in xorg.conf -- the driver is
expected to light the 2 monitors and get them cloned automatically.

The first issue here is LVDS is wrongly detected. So you can workaround it by
adding monitor-LVDS in xorg.conf (as you did), and adding option "ignored"
under monitor-LVDS section. On the other side we can see how to quirk it.

Anyway, you can't set 2 monitors with the same identifier "EXT". So you can
remove monitor-VGA and monitor-TV-1 related info from xorg.conf.

Please upload new log and xrandr output with above change.

(and remember to clear "NEEDINFO" from keyword field once you done)
Comment 12 Lew Shih Ming 2008-11-27 02:01:39 UTC
Hi,

I wish too that there are less machines so that I could test less but it's not call :) 

Anyway, sorry guys that I had posted incomplete logs previously. Added 2 new logs. 
Comment 13 Lew Shih Ming 2008-11-27 02:03:22 UTC
Created attachment 20623 [details]
xorg log with debug mode and 2 monitors connected to VGA ports
Comment 14 Lew Shih Ming 2008-11-27 02:06:35 UTC
Created attachment 20624 [details]
xrandr with verbose 2
Comment 15 Gordon Jin 2008-11-27 21:41:24 UTC
It seems you didn't do this:
The first issue here is LVDS is wrongly detected. So you can workaround it by
adding monitor-LVDS in xorg.conf (as you did), and adding option "ignored"
under monitor-LVDS section.

Once you do that, please attach xorg.conf so I can check if it's correct.
Comment 16 Stefan Dirsch 2008-11-28 00:19:54 UTC
I'm not aware of an option "ignored" for the monitor section. I think it needs to be

# man xorg.conf
[...]
Option "Ignore"  "bool"
              This optional entry specifies that the monitor should be ignored
              entirely, and not reported through RandR.  This is useful if the
              hardware  reports  the  presence  of  outputs  that don't exist.
              (RandR 1.2-supporting drivers only)

Non existing options are more or less silently "ignored". ;-)
Comment 17 Gordon Jin 2008-11-29 21:02:37 UTC
Stefan is right. The option should be "ignore". Sorry for my previous typo.
Comment 18 Lew Shih Ming 2008-11-30 01:39:57 UTC
Created attachment 20696 [details]
xorg.conf with ignore option in monitor section

I had added a new monitor section in the xorg.conf as shown below.

Section "Monitor"
  Identifier   "Monitor-LVDS"
  Option       "Ignore" "yes"
  HorizSync    30-61
  VertRefresh  43-75
  UseModes     "Modes[0]"
EndSection

Not too sure if I had done correctly, but xrandr still shows LVDS is connected.
Comment 19 Gordon Jin 2008-11-30 21:05:08 UTC
You need put monitor-LVDS under device section, like:

Section "Device"
  BoardName    "915 GM"
  Driver       "intel"
  Identifier   "Device[0]"
  Option       "monitor-VGA" "Monitor[0]"
  Option       "monitor-LVDS" "Monitor[1]"
  Option	"ModeDebug" "yes"
  Screen       0
  VendorName   "Intel"
EndSection

Section "Monitor"
  Identifier   "Monitor[1]"
  Option       "Ignore" "yes"
EndSection
Comment 20 Lew Shih Ming 2008-12-01 00:37:20 UTC
Created attachment 20711 [details]
xorg.conf with LVDS ignored

Thanks Gordon for your advice.

I had changed the xorg.conf according to your recommendations and xrandr did not detect the LVDS anymore.
Comment 21 Gordon Jin 2008-12-01 05:22:42 UTC
OK. Let's use this new xorg.conf with LVDS ignored. 
Now when you connect to both external VGA monitors, are they still blank? Please upload new log and xrandr output.
Comment 22 Lew Shih Ming 2008-12-01 18:58:09 UTC
Created attachment 20722 [details]
dmesg with disabled LVDS and 2 VGA connected
Comment 23 Lew Shih Ming 2008-12-01 19:02:22 UTC
Created attachment 20723 [details]
xorg with disabled LVDS and 2 VGA connected
Comment 24 Lew Shih Ming 2008-12-01 19:04:01 UTC
Created attachment 20724 [details]
xrandr verbose with disabled LVDS and 2 VGA connected
Comment 25 Lew Shih Ming 2008-12-01 19:06:31 UTC
Have attached dmesg, xorg log and xrandr verbose. Let me know if additional logs are required.
Comment 26 Gordon Jin 2008-12-01 19:30:12 UTC
We need get confirmed current sympton: "are they still blank?"

Zhenyu, so it detects "TV-1". This seems related to bug#18466.
Comment 27 Lew Shih Ming 2008-12-01 19:37:06 UTC
After ignoring LVDS, only primary monitor is able to display while the secondary monitor remains blank.

Previously, both are blank. 
Comment 28 Wang Zhenyu 2008-12-04 00:14:21 UTC
Lew, for now you can try Jesse's patch on bug #17823, https://bugs.freedesktop.org/attachment.cgi?id=20588, for you system to prefer SDVO VGA output.
Comment 29 Lew Shih Ming 2008-12-04 01:48:06 UTC
(In reply to comment #28)
> Lew, for now you can try Jesse's patch on bug #17823,
> https://bugs.freedesktop.org/attachment.cgi?id=20588, for you system to prefer
> SDVO VGA output.

I had read the bug #17823. 

In comment #12, you said that "With Jesse's patch, we will have fault type on this board. It looks we might have to find out what's the actually current SDVO output type."

My chipset is 915GM running on SLED. Will it be affected too?
Comment 30 Wang Zhenyu 2008-12-04 22:17:30 UTC
As you have no TV and only VGA output, Jesse's reorder patch should work for you. I have uploaded another patch trys to resolve this one, you can also try that in place of Jesse's patch.
Comment 31 qwang13 2008-12-08 00:49:48 UTC
(In reply to comment #29)
> My chipset is 915GM running on SLED. Will it be affected too?
> 

Lew Shih Ming,
Please try the patch, and give upstream the response. 
Thanks
Comment 32 Lew Shih Ming 2008-12-08 06:16:11 UTC
(In reply to comment #31)
> (In reply to comment #29)
> > My chipset is 915GM running on SLED. Will it be affected too?
> > 
> Lew Shih Ming,
> Please try the patch, and give upstream the response. 
> Thanks

Hi,

I am on vacation this entire week. I will try to reply once I get back on 15th Dec. Sorry for any inconvenience cause.

Thanks
Comment 33 Antonio Quizon 2008-12-08 22:10:27 UTC
guek wu will take over the testing until shih ming is on vacation 
Comment 34 Vance 2008-12-09 01:52:28 UTC
Created attachment 20943 [details]
xorg.conf

Hi, I will be following up on this issue while Shih Ming is away. I tried to follow this bug thread and recreate the xorg.conf as required but do let me know if I have missed out on anything. Ok, I have tried both Jesse and Zhenyu's patches separately. I downloaded the 2.5.0 source using git, applied the patches(original source used for each patch) using the patch -i <patchfile> command, ran ./autogen.sh, make and then make install. I then restarted the machine each time I installed the patched driver.

The bad news is that both patches did not seem to have an impact on the secondary display. The currently situation with either patches is that only the primary display can be seen while the secondary display is blank. I will be attaching the dmesg, Xorg.0.log and xrandr information for each patch.
Comment 35 Vance 2008-12-09 01:53:37 UTC
Created attachment 20944 [details]
dmesg Jesse Patch
Comment 36 Vance 2008-12-09 01:54:09 UTC
Created attachment 20945 [details]
Xorg.0.log Jesse Patch
Comment 37 Vance 2008-12-09 01:54:39 UTC
Created attachment 20946 [details]
xrandr Jesse Patch
Comment 38 Vance 2008-12-09 01:56:03 UTC
Created attachment 20947 [details]
dmesg Zhenyu's Patch
Comment 39 Vance 2008-12-09 01:57:06 UTC
Created attachment 20948 [details]
Xorg.0.log Zhenyu's Patch
Comment 40 Vance 2008-12-09 01:57:48 UTC
Created attachment 20949 [details]
xrandr Zhenyu
Comment 41 Michael Fu 2008-12-09 05:39:08 UTC
would you please attach the vbios rom? You can get it via:

# cd /sys/devices/pci0000\:00/0000\:00\:02.0/
# echo 1 > rom
# cat rom > /tmp/rom.bin
# echo 0 > rom

please attach the rom.bin then. thanks a lot!
Comment 42 Wang Zhenyu 2008-12-09 17:09:10 UTC
It doesn't look like you have loaded the patched driver. Try ./autogen.sh --prefix=/usr; make ; make install
Comment 43 Vance 2008-12-10 20:15:53 UTC
Created attachment 21030 [details]
Screenshot of Display with patch

Thanks for the tip Zhenyu. I recompiled the driver after applying your patch. In the attached screenshot, you can see a distorted display on the primary monitor. The secondary monitor is still blank. I will be attaching the usual logs for you to go through.
Comment 44 Vance 2008-12-10 20:17:08 UTC
Created attachment 21031 [details]
Dmesg Log
Comment 45 Vance 2008-12-10 20:18:58 UTC
Created attachment 21032 [details]
Xorg.0.log
Comment 46 Vance 2008-12-10 20:19:25 UTC
Created attachment 21033 [details]
Xandar --verbose
Comment 47 Vance 2008-12-10 20:20:09 UTC
Created attachment 21034 [details]
Rom Binary

Hi Michael, here's the rom.bin file you requested.
Comment 48 Michael Fu 2008-12-10 20:56:21 UTC
I noticed the xorg.conf file you used is different in the Monitor[0] section. Did you changed the VGA monitor that connect to the primary VGA connector on the machine? 

I'm asking because it's weird in Shih Ming's log the VGA EDID is successfully retrieved from the machine, while in your log it fails. I don't think Zhenyu's patch has anything to do with that... I assume you are testing on the same machine as Shih Ming, right?
Comment 49 Vance 2008-12-10 22:23:16 UTC
Created attachment 21040 [details]
xandr --verbose

You are right Michael. I am using a different monitor from the one Shih Ming used but the same machine is used. I was using a 12" monitor as a primary and a 15" as secondary. With the same xorg.conf, I switched the 15" screen(the one I presumed Shih Ming used originally) to be the primary and the 12" as the secondary. Upon reboot, both screens now display a cloned desktop without distortion. I am attaching the logs again. But any idea why the dual display don't work when connected the other way round?
Comment 50 Vance 2008-12-10 22:24:03 UTC
Created attachment 21041 [details]
Xorg.0.log
Comment 51 Vance 2008-12-10 22:26:43 UTC
Created attachment 21042 [details]
Dmesg
Comment 52 Michael Fu 2008-12-10 23:52:38 UTC
actually, even you exchange your monitor, the primary VGA still can't get EDID from the monitor attached to it.. I can't explain why in Shih Ming's test result , such as comment# 13, it can get EDID successfully, if the HW environment is the same... The Rom bin you attached indicate that the VGA should use GPIOC to do DDC, however, it still can't explain the log Shih Ming attached.
Comment 53 Vance 2008-12-11 02:38:32 UTC
Created attachment 21050 [details]
Xrandr

I am seeing a weird behavior that dual display only worked with certain combination of monitors, and even then, sometimes with the same combination that worked before, I couldn't see display on the second screen while the primary display is working. When it's not working, I would see Unknown-1 connected in xrandr's output. I am attaching the none working logs for the same monitor combination in comment 49. As for the EDID, I checked with Shih Ming and used the monitor he used in comment 13. The EDID information is also missing. Would the patch cause this since comment 13 was before the patching?
Comment 54 Vance 2008-12-11 02:39:15 UTC
Created attachment 21051 [details]
Xorg.0.log
Comment 55 Vance 2008-12-11 02:39:37 UTC
Created attachment 21052 [details]
Dmesg
Comment 56 Lew Shih Ming 2008-12-11 07:20:25 UTC
hi Michael, 

The xorg log from comment #13 is collected from another machine of the same model. Sorry for the confusion guys.

Does the EDID information important such as causing the VGA to mulfunction?
Comment 57 Michael Fu 2008-12-12 21:34:19 UTC
(In reply to comment #56)
> hi Michael, 
> 
> The xorg log from comment #13 is collected from another machine of the same
> model. Sorry for the confusion guys.
> 
> Does the EDID information important such as causing the VGA to mulfunction?
> 

Shih Ming, Do you still have access to that machine? If so, would you be able to help get a rom.bin as I asked in comment# 41. thanks!

To answer your question, yes, EDID is important to get a proper display on the screen.
Comment 58 Michael Fu 2008-12-14 18:40:21 UTC
(In reply to comment #53)
> Created an attachment (id=21050) [details]
> Xrandr
> 
> I am seeing a weird behavior that dual display only worked with certain
> combination of monitors, and even then, sometimes with the same combination
> that worked before, I couldn't see display on the second screen while the
> primary display is working. When it's not working, I would see Unknown-1
> connected in xrandr's output. I am attaching the none working logs for the same
> monitor combination in comment 49. As for the EDID, I checked with Shih Ming
> and used the monitor he used in comment 13. The EDID information is also
> missing. Would the patch cause this since comment 13 was before the patching?
> 

Vance, would you please try this patch to see if it can resolve the "missing EDID on the primary monitor" issue on your board. https://bugs.freedesktop.org/attachment.cgi?id=20593

The "secondary display sometimes works, sometimes doesn't" issue will be tricky. From the log, it's the SDVO device sometimes can't detect the monitor connected it it.

BTW, no need for dmesg, just xorg.log with ModeDebug turns on should be enough.

thanks.
Michael
Comment 59 Lew Shih Ming 2008-12-15 02:41:18 UTC
Created attachment 21162 [details]
rom.bin from old machine

(In reply to comment #57)
> (In reply to comment #56)
> > hi Michael, 
> > 
> > The xorg log from comment #13 is collected from another machine of the same
> > model. Sorry for the confusion guys.
> > 
> > Does the EDID information important such as causing the VGA to mulfunction?
> > 
> Shih Ming, Do you still have access to that machine? If so, would you be able
> to help get a rom.bin as I asked in comment# 41. thanks!
> To answer your question, yes, EDID is important to get a proper display on the
> screen.

hi Michael,

I had attached the rom.bin from the old machine for your review. **This old machine had not been patched. Let me know if there is a need to have the patch from comment #58 on this machine as well.

FYI: this old machine will not be used for further testing anymore. We will be testing on the machine that Vance had collected the logs from. 


Thanks
Comment 60 Wang Zhenyu 2008-12-15 22:04:19 UTC
oh, my second patch on #17823 is wrong, please test with jesse's patch for now. that's https://bugs.freedesktop.org/attachment.cgi?id=20588
Comment 61 Michael Fu 2008-12-15 22:34:27 UTC
(In reply to comment #60)
> oh, my second patch on #17823 is wrong, please test with jesse's patch for now.
> that's https://bugs.freedesktop.org/attachment.cgi?id=20588
> 

this probably will only help the issue in comment# 53.
Comment 62 Lew Shih Ming 2008-12-15 22:49:53 UTC
(In reply to comment #61)
> (In reply to comment #60)
> > oh, my second patch on #17823 is wrong, please test with jesse's patch for now.
> > that's https://bugs.freedesktop.org/attachment.cgi?id=20588
> > 
> this probably will only help the issue in comment# 53.

Hi Zhenyu and Michael,

I had updated the patch base on comment #58 and just about to send the Xorg log :) Do you guys still need it? 

At the mean time, will retest the new machines using Jesse's.
Comment 63 Lew Shih Ming 2008-12-16 02:49:55 UTC
Created attachment 21204 [details]
xorg log after patch
Comment 64 Wang Zhenyu 2008-12-16 18:36:04 UTC
Lew, you looks still keep my debug patch. Please try a origin driver with only Jesse's patch. 
Comment 65 Lew Shih Ming 2008-12-18 03:07:04 UTC
Created attachment 21271 [details]
xorg log after jessie patch on xf86-video-intel-2.5.0

This was collected after patching Jessie's patch on xf86-video-intel-2.5.0.
Comment 66 Lew Shih Ming 2008-12-18 03:11:10 UTC
Created attachment 21272 [details]
xrandr after jessie's patch on xf86-video-intel-2.5.0
Comment 67 Lew Shih Ming 2008-12-18 03:19:57 UTC
Created attachment 21273 [details]
screenshot of clone displays

This is a screenshot of my dual displays after Jessie's patch and adding a Option for PreferredMode of 1024x768 in the Monitor section of xorg.conf. Before adding this line in the xorg.conf, both screens were 800x600. 

Again my monitors are unable to pick up automatically by xorg.conf (same as Vance's). Checked the xorg log files, EDID are found. Checked hwinfo --monitor, no monitors are found.
Comment 68 Michael Fu 2008-12-21 23:50:59 UTC
(In reply to comment #65)
> Created an attachment (id=21271) [details]
> xorg log after jessie patch on xf86-video-intel-2.5.0
> 
> This was collected after patching Jessie's patch on xf86-video-intel-2.5.0.
> 

Shil Ming, it seems the bug now turns to "why primary VGA can't get EDID from monitor". 

Would you please try vesa driver and attach the log? The purpose is to see vesa driver can read out the EDID.. thanks.
Comment 69 Wang Zhenyu 2008-12-21 23:54:28 UTC
It looks your second SDVO VGA issue is gone. And your xorg.conf has been set to pick up 800x600 mode. Please try to remove it in xorg.conf and any clock range limit, to let 1024x768 mode not disabled.
Comment 70 Lew Shih Ming 2008-12-22 02:37:35 UTC
Created attachment 21389 [details]
xorg.conf after removing Freq

Hi Zhenyu,

I had both screens displaying 1024x768 after removing the HorizSync and VertRefresh in the Monitor section. I also remove all the 800x600 values in the Screen section. I am attaching the xorg.conf and xrandr.
Comment 71 Lew Shih Ming 2008-12-22 02:39:11 UTC
Created attachment 21390 [details]
xrandr --verbose after removing Freq.
Comment 72 Lew Shih Ming 2008-12-22 03:34:09 UTC
Created attachment 21396 [details]
xorg log using vesa

hi Michael,

I have problem to run X window using vesa driver as it gives me gdm error. Only after I remove all the virtual values in the Screen section as well as HorizSync from the Monitor section then I could start X. 

I could not find any EDID values in the xorg log even after booting up with different monitors.
Comment 73 Michael Fu 2008-12-22 19:35:19 UTC
(In reply to comment #70)
> Created an attachment (id=21389) [details]
> xorg.conf after removing Freq
> 
> Hi Zhenyu,
> 
> I had both screens displaying 1024x768 after removing the HorizSync and
> VertRefresh in the Monitor section. I also remove all the 800x600 values in the
> Screen section. I am attaching the xorg.conf and xrandr.
> 

Shih Ming,

It seems that even bios can't successfully detect the EDID from the primary VGA. You would need to esccalate this issue to your HW team to double check this. A useful information for them is you once can get the EDID on the HW in comment# 13. 

However, this can work around this, as you can see, through xorg.conf to specify a modeline that works with the monitor. you could stay with this solution, too.
Comment 74 Lew Shih Ming 2008-12-22 22:37:41 UTC
Hi Michael,

Thanks for the tip and I will raise it to the HW folks. Since after patching the driver, I still need to ignore LVDS in the xorg.conf in order to have my 2nd VGA working. Does this consider a fixed or just a temperory workaround? 
Comment 75 Michael Fu 2008-12-22 22:58:01 UTC
(In reply to comment #74)
> Hi Michael,
> 
> Thanks for the tip and I will raise it to the HW folks. Since after patching
> the driver, I still need to ignore LVDS in the xorg.conf in order to have my
> 2nd VGA working. Does this consider a fixed or just a temperory workaround? 
> 

zhenyu has a patch for bug# 18462 which is reported by your team ,too. Please try that patch and attach the xorg.log with modedebug turns on...
Comment 76 Michael Fu 2009-01-05 19:26:07 UTC
(In reply to comment #74)
> Hi Michael,
> 
> Thanks for the tip and I will raise it to the HW folks. Since after patching
> the driver, I still need to ignore LVDS in the xorg.conf in order to have my
> 2nd VGA working. Does this consider a fixed or just a temperory workaround? 
> 

Shih Ming, any response from  your HW team? Have you tried the patch in bug# 18462 to see if it addressed your LVDS issue?
Comment 77 Lew Shih Ming 2009-01-05 19:45:58 UTC
(In reply to comment #76)
> (In reply to comment #74)
> > Hi Michael,
> > 
> > Thanks for the tip and I will raise it to the HW folks. Since after patching
> > the driver, I still need to ignore LVDS in the xorg.conf in order to have my
> > 2nd VGA working. Does this consider a fixed or just a temperory workaround? 
> > 
> Shih Ming, any response from  your HW team? Have you tried the patch in bug#
> 18462 to see if it addressed your LVDS issue?

Michael,

We had faced similar problem detecting IBM monitors before and I am trying to recify it using Novell recommanded tools currently. I will update you once I recieved a reply from our HW team. 
Comment 78 Lew Shih Ming 2009-01-08 01:39:36 UTC
Hi Michael,

The H/W folks have came back to me that there is a rework for our test unit regarding the VGA defect. Apparently, we are waiting for the new board to be shipped to us. I will test it immediately once I receive it. Thanks.
Comment 79 Wang Zhenyu 2009-01-08 18:42:17 UTC
There might be possible the monitor is broken without EDID info, I think that's common on older hw. As current problem looks only for VGA EDID missing issue, and we can always use default modes like 1024x768 on them. Origin problem has been fixed in bug# 18462, and patches are upstream now. So close this one. 
Comment 80 Lew Shih Ming 2009-01-08 19:37:30 UTC
(In reply to comment #79)
> There might be possible the monitor is broken without EDID info, I think that's
> common on older hw. As current problem looks only for VGA EDID missing issue,
> and we can always use default modes like 1024x768 on them. Origin problem has
> been fixed in bug# 18462, and patches are upstream now. So close this one. 


Hi Zhenyu,

Can we leave this bug open till we verified the new driver in Novell's next release and our reworked H/W?
Comment 81 Lew Shih Ming 2009-01-12 03:45:30 UTC
Created attachment 21894 [details]
xorg log after replacing reworked HW

Hi Zhenyu,

I had replaced with a reworked HW. EDID now is able to detect but the result is still the same as comment #67(screenshot). I followed your recommandation and comment out the Freq in xorg.conf file in order to be fit the resolution nicely into both monitors.
Comment 82 Lew Shih Ming 2009-01-12 03:51:30 UTC
Created attachment 21895 [details]
xrandr --verbose after replaced reworked HW

Zhenyu,

I saw your comment #24 from bug 17823 that you have another patch update. Does it fix my problem too?

As for bug 18462, I do not see any similarities with this bug. Could you clarify? 

Thanks
Comment 83 Wang Zhenyu 2009-01-14 17:47:21 UTC
Looks EDID might still be broken, but default 1024x768 vesa mode should always work.

You should add "1024x768" in Screen section's Modes, or completely remove that line.
Or add a Monitor section for VGA like

Section "Monitor"
  Identifier	"Monitor[0]"
  # 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
  Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
  Option "PreferredMode" "1024x768_60.00"
EndSection

Comment 84 Lew Shih Ming 2009-01-18 22:35:11 UTC
(In reply to comment #83)
> Looks EDID might still be broken, but default 1024x768 vesa mode should always
> work.
> You should add "1024x768" in Screen section's Modes, or completely remove that
> line.
> Or add a Monitor section for VGA like
> Section "Monitor"
>   Identifier    "Monitor[0]"
>   # 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
>   Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798
> -hsync +vsync
>   Option "PreferredMode" "1024x768_60.00"
> EndSection

Zhenyu,

I had summarized what I had tested on xorg settings:- 
I removed the section Mode completely and replaced "800x640" with "1024x768" in the subsection Display of section Screen then both 15" monitors are able to display the correct resolution. But I will always need to set back to "800x600" whenever I use 12" monitors. Adding PreferredMode option in the section Monitor does not help. I tried to add both resolutions in the subsection displays but it seems that it always use the 1st resolution settings. E.g. Modes "1024x768" "800x600", will always use 1024x768.

As for the suspicion of EDID defect, could you provide more details so that our H/W team could pin down the problem ASAP. They have tested with Windows and are working fine. I will try to collect all the logs that you need. 

Thanks
Comment 85 qwang13 2009-01-19 17:43:32 UTC
(In reply to comment #84)
> (In reply to comment #83)
> > Looks EDID might still be broken, but default 1024x768 vesa mode should always
> > work.
> > You should add "1024x768" in Screen section's Modes, or completely remove that
> > line.
> > Or add a Monitor section for VGA like
> > Section "Monitor"
> >   Identifier    "Monitor[0]"
> >   # 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
> >   Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798
> > -hsync +vsync
> >   Option "PreferredMode" "1024x768_60.00"
> > EndSection
> 
> Zhenyu,
> 
> I had summarized what I had tested on xorg settings:- 
> I removed the section Mode completely and replaced "800x640" with "1024x768" in
> the subsection Display of section Screen then both 15" monitors are able to
> display the correct resolution. But I will always need to set back to "800x600"
> whenever I use 12" monitors. Adding PreferredMode option in the section Monitor
> does not help. I tried to add both resolutions in the subsection displays but
> it seems that it always use the 1st resolution settings. E.g. Modes "1024x768"
> "800x600", will always use 1024x768.
Stefan, is there some configuration for this? You are familiar with the configuration. Maybe you can provide some good idea for this.

> 
> As for the suspicion of EDID defect, could you provide more details so that our
> H/W team could pin down the problem ASAP. They have tested with Windows and are
> working fine. I will try to collect all the logs that you need. 
>
Zhenyu, is it possible to provide more details for this?
 
> Thanks
> 

Comment 86 Stefan Dirsch 2009-01-19 17:49:38 UTC
Quanxian, you can use 'sax2 -l' to create a low resolution configuration.

# sax2 --help
[...]
[ -l | --lowres ]
  use only 800x600@60 Hz standard mode.
  DDC detection is switched off in this case
Comment 87 qwang13 2009-01-19 18:09:45 UTC
(In reply to comment #86)
> Quanxian, you can use 'sax2 -l' to create a low resolution configuration.
> 
> # sax2 --help
> [...]
> [ -l | --lowres ]
>   use only 800x600@60 Hz standard mode.
>   DDC detection is switched off in this case
> 

I think Lew Shih Ming want to use one xorg.conf to support different resolution.
one is 800x600 to support 12' monitor, another is 1024x768 to support 15' monitor. Please read his comment 84. when they switch to any monitor, it will be convenient for them to change the resolution they want by xrandr or other tools instead of touching xorg.conf.

Lew Shih Ming, would you like to try the method provided by Stefan?

Thanks
Comment 88 Lew Shih Ming 2009-01-20 08:28:27 UTC
(In reply to comment #87)
> (In reply to comment #86)
> > Quanxian, you can use 'sax2 -l' to create a low resolution configuration.
> > 
> > # sax2 --help
> > [...]
> > [ -l | --lowres ]
> >   use only 800x600@60 Hz standard mode.
> >   DDC detection is switched off in this case
> > 
> I think Lew Shih Ming want to use one xorg.conf to support different
> resolution.
> one is 800x600 to support 12' monitor, another is 1024x768 to support 15'
> monitor. Please read his comment 84. when they switch to any monitor, it will
> be convenient for them to change the resolution they want by xrandr or other
> tools instead of touching xorg.conf.
> Lew Shih Ming, would you like to try the method provided by Stefan?
> Thanks

Sure, will test out Stefan's method right away.  

You are right that we are supporting many different monitors, more than 10 IBM models. Thanks for the clarification. 
Comment 89 Lew Shih Ming 2009-01-22 20:25:43 UTC
Created attachment 22160 [details]
xorg after sax2 -l
Comment 90 Lew Shih Ming 2009-01-22 20:28:28 UTC
Created attachment 22161 [details]
xrandr after sax2 -l

This 2 files are what I got after applying sax2 -l.
Comment 91 Lew Shih Ming 2009-02-03 22:50:21 UTC
(In reply to comment #87)
> (In reply to comment #86)
> > Quanxian, you can use 'sax2 -l' to create a low resolution configuration.
> > 
> > # sax2 --help
> > [...]
> > [ -l | --lowres ]
> >   use only 800x600@60 Hz standard mode.
> >   DDC detection is switched off in this case
> > 
> I think Lew Shih Ming want to use one xorg.conf to support different
> resolution.
> one is 800x600 to support 12' monitor, another is 1024x768 to support 15'
> monitor. Please read his comment 84. when they switch to any monitor, it will
> be convenient for them to change the resolution they want by xrandr or other
> tools instead of touching xorg.conf.
> Lew Shih Ming, would you like to try the method provided by Stefan?
> Thanks

Hi,

sax2 -l on sles11 RC3 does not work. I'm not sure if the driver has been updated in this release.
Comment 92 Stefan Dirsch 2009-02-03 23:37:51 UTC
updated with/to what?
Comment 93 Lew Shih Ming 2009-02-04 00:28:25 UTC
(In reply to comment #92)
> updated with/to what?

With reference to comment #29, I added the patch to xf86-video-intel-2.5.0 to make it work where RC1 and RC2 have the dual display problem. Does the latest intel driver solve this bug? If it is already fixed, will be available in RC4?
Comment 94 Stefan Dirsch 2009-02-04 00:48:40 UTC
Lew, RC3 does not include Jesse's reorder patch, which prefers VGA instead of (possibly false) detecting TV output.
Comment 95 Lew Shih Ming 2009-02-04 01:10:19 UTC
(In reply to comment #94)
> Lew, RC3 does not include Jesse's reorder patch, which prefers VGA instead of
> (possibly false) detecting TV output.

Thanks for the info. Is there any plan to make it available for the upcoming releases? Enabling the dual display is our current top priority to meet our machine GA date. 
Comment 96 Stefan Dirsch 2009-02-04 01:14:16 UTC
Lew, I suggest to do further discussing in Bug #17823.