Bug 18839 - X fails to find any devices when there's more than one in the system
X fails to find any devices when there's more than one in the system
Status: RESOLVED DUPLICATE of bug 18321
Product: xorg
Classification: Unclassified
Component: Server/General
git
Other All
: medium major
Assigned To: Xorg Project Team
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 16:55 UTC by Aaron Plattner
Modified: 2008-12-30 14:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
config (63 bytes, application/octet-stream)
2008-12-01 16:56 UTC, Aaron Plattner
no flags Details
log (9.43 KB, text/x-log)
2008-12-01 16:56 UTC, Aaron Plattner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Plattner 2008-12-01 16:55:57 UTC
I set up a system with two PCI-E devices, one at PCI:1:0:0 and one (the primary) at PCI:2:0:0.  Without specifying the BusID, the X server decides that they're both primary,

  (!!) More than one possible primary device found
  (--) PCI: (0@1:0:0) unknown vendor (0x10de) unknown chipset (0x05fd) rev 161, Mem @ 0xc6000000/16777216, 0xa0000000/268435456, 0xc4000000/33554432, I/O @ 0x00003000/128
  (--) PCI: (0@2:0:0) unknown vendor (0x10de) unknown chipset (0x06ea) rev 161, Mem @ 0xc2000000/16777216, 0xb0000000/268435456, 0xc0000000/33554432, I/O @ 0x00002000/128

and then that neither are primary,

  (II) Primary Device is:
  (EE) No devices detected.

and then fails to start:

  Fatal server error:
  no screens found

This is a problem at least as far back as server-1.5-branch.  Specifying BusIDs works around the problem except that the server decides not to POST the secondary GPU.
Comment 1 Aaron Plattner 2008-12-01 16:56:24 UTC
Created attachment 20720 [details]
config
Comment 2 Aaron Plattner 2008-12-01 16:56:40 UTC
Created attachment 20721 [details]
log
Comment 3 Timo Aaltonen 2008-12-30 14:52:31 UTC

*** This bug has been marked as a duplicate of bug 18321 ***