Bug 18994 - [i965 gem] glsl/convolutions fails
[i965 gem] glsl/convolutions fails
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: Ian Romanick
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 23:56 UTC by lin, jiewen
Modified: 2009-05-14 01:51 UTC (History)
0 users

See Also:


Attachments
log (46.02 KB, text/plain)
2008-12-09 23:56 UTC, lin, jiewen
Details
conf (3.76 KB, text/plain)
2008-12-09 23:56 UTC, lin, jiewen
Details
screenshot (100.91 KB, image/png)
2008-12-09 23:58 UTC, lin, jiewen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lin, jiewen 2008-12-09 23:56:06 UTC
Created attachment 20982 [details]
log

System Environment:
--------------------------

--Platform: 965
--Architecture(32-bit,64-bit,compatiblity): 32-bit
--2D driver: (xf86-video-intel-2.6-branch)                                     
6ca0d7e6ff05bff2bb88bfae64c2d79ac115bd38
--3D driver: (intel-2008-q4)154a9e5317f890618932cea0129ef887e16baf84
--DRM:shipped with kernel 2.6.28-rc6 for-airlied
--libdrm: (master)c99566fb810c9d8cae5e9cd39d1772b55e2f514c
--Xserver: (server-1.6-branch)b268458eab2f213ec14dfe8013aa714c187e3aab
--Kernel: 2.6.28-rc6 for-airlied

Bug detailed description:
--------------------------
start X and convolutions, the display is not correct. Details could be got in the
attachment screenshot.

Reproduce steps:
----------------
1. xinit &
2. ./convolutions
Comment 1 lin, jiewen 2008-12-09 23:56:46 UTC
Created attachment 20983 [details]
conf
Comment 2 lin, jiewen 2008-12-09 23:58:22 UTC
Created attachment 20984 [details]
screenshot

On the pic, the left window is software rendering(normal), and the right
one is direct rendering.
Comment 3 Gordon Jin 2008-12-10 05:18:23 UTC
The case is under mesa/progs/glsl/
Comment 4 Ian Romanick 2008-12-16 17:10:40 UTC
This test seems to fail because the ARL instruction is not implemented.  This isn't too surprising since this instruction is not part of ARB_fragment_program.  I tried hacking up an implementation, but the test still failed.  I don't really understand the difference between vertex shaders and fragment shaders on 965 hardware.
Comment 5 lin, jiewen 2009-01-16 00:24:16 UTC
This issue still eixsts with current build.
Comment 6 Eric Anholt 2009-05-06 12:55:19 UTC
Works fine on master and 7.4 branch.
Comment 7 liuhaien 2009-05-14 01:51:42 UTC
verified against:
Libdrm:         (master)8b8e20e0f9900fae23baee55a91533a739c1a3ec
Mesa:           (master)10c4a10b979bddd099287dec5b69243c2ade8ade
Xserver:                (master)f3c61377d0fb1f09a18833995556fc9ffd11e097
Xf86_video_intel:              
(master)52367847087206b92f18c40d356d36ab9ee89d39
Kernel:             (for-linus)79f11c19a396e8cea7dad322dcfb46c0a8517fe6