Bug 19150 - [i915 GEM]low performance when run mesa demo/cubemap
Summary: [i915 GEM]low performance when run mesa demo/cubemap
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: haihao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-17 20:56 UTC by liuhaien
Modified: 2008-12-18 01:18 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg conf file (4.03 KB, text/plain)
2008-12-17 20:56 UTC, liuhaien
Details
xorg.0.log (41.45 KB, text/plain)
2008-12-17 20:57 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-12-17 20:56:46 UTC
Created attachment 21258 [details]
xorg conf file

System Environment:
--------------------------
host:x-bl2
arch: x86_64
Libdrm:         (master)c86d431fe6174b1c2de531929213ea7dbd92326d
Mesa_stable:    (intel-2008-q4)0d5b1e591b7fb2cf3109b7e147bb3ea6aa8f8b15
Xserver_stable:  (server-1.6-branch)32e81074b967716865aef08b66ec29caf0fec2c5
Xf86_video_intel_stable:  (xf86-video-intel-2.6-branch)
              83f3c376b5942e134047a220e6e5f2432ffc492c


Bug detailed description:
-------------------------
start X, then run cubemap, we will get a very low performance.

Reproduce steps:
----------------
1.xinit&
2. run mesa demo/cubemap
Comment 1 liuhaien 2008-12-17 20:57:13 UTC
Created attachment 21259 [details]
xorg.0.log
Comment 2 Eric Anholt 2008-12-17 21:12:13 UTC
git-bisect?
sysprof?
INTEL_DEBUG=fall?
Comment 3 liuhaien 2008-12-17 22:29:38 UTC
haihao has got the reason of this issue, so I reassign it to him.
Comment 4 haihao 2008-12-17 23:01:07 UTC
fixed in mesa.

commit cb453244caa15342bf229ee5ae16a78d038b8bdc
Author: Xiang, Haihao <haihao.xiang@intel.com>
Date:   Thu Dec 18 12:57:41 2008 +0800

    i915: check WRAP_T instead of WRAP_R for cube map texture.

Note apps those don't use  CLAMP_TO_EDGE/CLAMP for cube map texture have to suffer from fallbacks.
Comment 5 liuhaien 2008-12-18 01:18:22 UTC
verified against:
intel-2008-q4 branch commit f96baeaac3ef41260ac3975750627ece073fdce0
master commit cb453244caa15342bf229ee5ae16a78d038b8bdc 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.