Bug 19252 - gpk-update-viewer: description text not selectable
Summary: gpk-update-viewer: description text not selectable
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
: 19254 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-23 04:19 UTC by Aaron Kaplan
Modified: 2012-01-05 10:13 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Kaplan 2008-12-23 04:19:21 UTC
If I want to keep notes about a package that's being updated, I can't copy-and-paste from the gpk-update-viewer window, because the description text is not selectable.  I have to type it in by hand.

Also, the mouse cursor behavior over the description is strange.  Usually it's a text selection cursor; if I go over a URL it changes to the pointing finger (which is fine), but then when I go back to some non-URL text it remains a pointing finger.
Comment 1 Richard Hughes 2009-01-02 00:36:29 UTC
*** Bug 19254 has been marked as a duplicate of this bug. ***
Comment 2 Michal Nowak 2009-01-15 04:07:35 UTC
I can see both of them. Especially the first one annoying, when developer puts there link with Changelog on the web, it's horror to write. 

It'd be good if PackageKit percepts the URI and create the a link from it but doing this function specially for PackageKit looks weird, support on GTK would be nice.

Another fix could be to teach packagers to put the text behind the link, not the link itself. But that's long-way run.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.