Bug 19296 - Zero Ballistics: failed to compile shader
Summary: Zero Ballistics: failed to compile shader
Status: RESOLVED DUPLICATE of bug 14448
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact:
URL: http://www.zeroballistics.com/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-26 08:18 UTC by Sven Arvidsson
Modified: 2009-08-24 12:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
ZB log file (12.38 KB, text/plain)
2008-12-26 08:18 UTC, Sven Arvidsson
Details

Description Sven Arvidsson 2008-12-26 08:18:57 UTC
Created attachment 21495 [details]
ZB log file

The beta of the game Zero Ballistics fails to run. This happens both in hardware mode, and with the software rasterizer.

 Failed to compile shader "terrain_morph".

I'm attaching the error log from the game, which seems to include the shaders which fails.

http://www.zeroballistics.com/
Comment 1 Sven Arvidsson 2009-03-16 07:20:22 UTC
Using commit 2305642b2e8edcebdc727f1181f7dbfcc78e8028 it no longer fails on the shaders but gives this error:

tank.x86: brw_curbe.c:87: calculate_curbe_offsets: Assertion `total_regs <= 32' failed.


*** This bug has been marked as a duplicate of bug 14448 ***
Comment 2 Adam Jackson 2009-08-24 12:31:30 UTC
Mass version move, cvs -> git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.