Bug 19822 - OpenGL performance regression on Intel 855GM (libdrm 2.3.1 -> libdrm-intel 2.4.4)
OpenGL performance regression on Intel 855GM (libdrm 2.3.1 -> libdrm-intel 2....
Status: RESOLVED INVALID
Product: DRI
Classification: Unclassified
Component: libdrm
unspecified
Other All
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 00:02 UTC by Diego Escalante Urrelo
Modified: 2009-03-26 11:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Escalante Urrelo 2009-01-30 00:02:06 UTC
So I upgraded to jaunty and turns out that the intel driver 2.6.1 + libdrm-intel 2.4.4 (that perhaps is not precisely libdrm) makes opengl run SLOW; apparently based using software rendering; while intel driver 2.4.1 + libdrm 2.3.1 (from intrepid), everything is perfect and performance is good.

In one line: libdrm-intel 2.4.4 + intel driver 2.6.1 = slow opengl (apparently being rendered with software); libdrm 2.3.1 + intel driver 2.4.1 = good opengl.

:)

Am I missing something, or perhaps there's a dependency on a more recent version of something?
Comment 1 Diego Escalante Urrelo 2009-01-31 00:02:07 UTC
I must correct myself, kernel 2.6.28 was necessary to get a good performance. Although, the performance has indeed degraded a bit, like 10fps less with glxgears maximized to my 1024x768 screen.
Comment 2 Diego Escalante Urrelo 2009-03-26 11:26:07 UTC
Marking invalid, will report a new one if I find a bigger regression.
Comment 3 Diego Escalante Urrelo 2009-03-26 11:26:18 UTC
Marking invalid, will report a new one if I find a bigger regression.