Bug 19951 - On boot, TV output is enabled; breaks laptop/projector use case
Summary: On boot, TV output is enabled; breaks laptop/projector use case
Status: RESOLVED DUPLICATE of bug 20008
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium major
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-04 06:15 UTC by Bryce Harrington
Modified: 2009-02-08 23:07 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
XorgLog.txt (23.71 KB, text/plain)
2009-02-04 06:15 UTC, Bryce Harrington
no flags Details
Xrandr.txt (5.73 KB, text/plain)
2009-02-04 06:16 UTC, Bryce Harrington
no flags Details

Description Bryce Harrington 2009-02-04 06:15:51 UTC
Created attachment 22574 [details]
XorgLog.txt

Forwarding this bug from a Ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/325289

[Problem]
This hardware has an SVideo output, and on boot xrandr reports the TV output as enabled when nothing is connected to it.  As a result, plugging in a monitor or projector via VGA fails to work, requiring manually disabling the TV output first.

[Original Report]
This laptop has an S-Video output, and when booting it enables the TV output for it, even though nothing is connected. This is a problem because if connecting to an external monitor or projector via VGA, it requires several additional steps to make it work.

As a workaround, I can manually disable the TV output, and then enable the VGA output. This can be done using the xrandr command line tool, but there is no mechanism for doing this just with the GUI screen resolution tool, so it won't be obvious for most users.

distro:             Ubuntu
 architecture:       x86_64
 kernel:             2.6.28-6-generic
 xserver-xorg:       1:7.4~5ubuntu11
 mesa:               7.3-1ubuntu1
 libdrm:             2.4.4-0ubuntu4
 -intel:             2:2.6.1-1ubuntu1
 -ati:               1:6.10.0-1ubuntu1

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.6.1-1ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/zsh
ProcVersion: Linux version 2.6.28-6-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-3ubuntu1) ) #17-Ubuntu SMP Fri Jan 30 15:35:08 UTC 2009

SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-6-generic x86_64

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
	Subsystem: Hewlett-Packard Company Device [103c:30bb]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
	Subsystem: Hewlett-Packard Company Device [103c:30bb]
Comment 1 Bryce Harrington 2009-02-04 06:16:22 UTC
Created attachment 22575 [details]
Xrandr.txt
Comment 2 Wang Zhenyu 2009-02-08 18:21:59 UTC
Please attach log with ModeDebug on. XorgLog.txt showed correct detect result as TV is disconnected, attached wrong log?
Comment 3 Michael Fu 2009-02-08 23:07:44 UTC

*** This bug has been marked as a duplicate of bug 20008 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.