Bug 19963 - libdrm-2.4.4: slow 3D performance on intel 965gm after suspend to ram
libdrm-2.4.4: slow 3D performance on intel 965gm after suspend to ram
Status: RESOLVED DUPLICATE of bug 19675
Product: DRI
Classification: Unclassified
Component: libdrm
XOrg git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 05:14 UTC by Uros
Modified: 2009-06-16 04:12 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg config (2.45 KB, application/octet-stream)
2009-02-05 05:14 UTC, Uros
no flags Details
xorg log (21.43 KB, application/octet-stream)
2009-02-05 05:14 UTC, Uros
no flags Details
dmesg log (30.17 KB, text/plain)
2009-02-05 05:15 UTC, Uros
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uros 2009-02-05 05:14:06 UTC
Created attachment 22606 [details]
xorg config

After returning from suspend-to-ram, 3D accel. is not working as expected -- meaning, compiz 0.7.8 becomes unusable -- untill reboot that is.

And the fun part? It works as intended with libdrm-2.4.3 (after rebuilding
everything and rebooting).. sometimes..

With libdrm-2.4.3 system experiences such simptoms as described at https://bugs.freedesktop.org/show_bug.cgi?id=17807 -- random square blip under mouse cursor, touchpad working but every other input dead after returning from suspend-to-ram -- also at one time there was a message about xorg being in infinite loop.

Trading one annoying problem for another.

I'll attach all related logs below. Please let me know if you need something else.

Using:
- libdrm-2.4.4
- xf86-video-intel-2.6.1
- xorg-server-1.5.3
- mesa-7.3
- EXA accel method
- DRI
Comment 1 Uros 2009-02-05 05:14:42 UTC
Created attachment 22607 [details]
xorg log
Comment 2 Uros 2009-02-05 05:15:18 UTC
Created attachment 22608 [details]
dmesg log
Comment 3 Uros 2009-02-05 14:32:07 UTC
Sorry for not noticing another bug report before posting ... almost the same problem with restarting/reloading xorg and performance degradation (libdrm-2.4.4) @ http://bugs.freedesktop.org/show_bug.cgi?id=19675
Comment 4 Uros 2009-06-16 04:12:04 UTC

*** This bug has been marked as a duplicate of bug 19675 ***