Bug 20225 - [HD3470 + HD3200] Dual cards prevents X from starting / black screen
Summary: [HD3470 + HD3200] Dual cards prevents X from starting / black screen
Status: RESOLVED DUPLICATE of bug 18321
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.4 (2008.09)
Hardware: Other Linux (All)
: high normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL: https://bugs.edge.launchpad.net/ubunt...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-19 14:25 UTC by Bryce Harrington
Modified: 2009-02-24 13:18 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log from an earlier -ati version. More recent -ati's give the same errors (25.70 KB, patch)
2009-02-19 14:25 UTC, Bryce Harrington
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2009-02-19 14:25:52 UTC
Created attachment 23121 [details] [review]
Xorg.0.log from an earlier -ati version.  More recent -ati's give the same errors

[Problem]
X gets confused by the presence of two primary graphics devices, resulting in "no screens found" and X exiting.  It also gives this warning:

  (!!) More than one possible primary device found

This issue was first seen in Intrepid (6.9.0+git) but is also still being seen in Jaunty.  It is seen with a variety of drivers including radeonhd (see fdo bug #19513), and it seems to crap out before the driver starts printing its messages, so might rather be an xserver issue, but filing here against -ati just in case.

[Original Report]
The specs:
Asus x56tr Notebook
AMD TURION X2 64
ATI 3200 & ATI HD3470
RAM 4GB

I can install Intrepid Ibex, but my graphics cards don't work in Intrepid.

Installing Ubuntu only works with the extra boot options acpi=off or MAXCPUS=1. Ubuntu Intrepid installed, but i couldn't get any GUI. The x-server tried to start but failed. I also cannot switch to terminal using crtl-alt F1, because X keeps trying. sometimes i get the error message: no screens found. I tried ati, radeon, vesa, radeonhd. I tried installing the official ati-drivers. Nothing worked, then after hours of mindbreaking i installed Hardy Heron, IT worked! Installed the restricted drivers and the screen looks nice. No sound though and no wireless.

How can i get Intrepid Ibex to work? I read somewhere that xorg 7.4 could be the problem or the 4GB of RAM. Don't know how to fix this though. Latest versions of Mandriva and OpenSuse also do not run from livecd or install and suse complains about the graphic card.

[lspci]
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
     Subsystem: ASUSTeK Computer Inc. Device [1043:11e7]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] [1002:9612]
     Subsystem: ASUSTeK Computer Inc. Device [1043:1062]
02:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4]
     Subsystem: ASUSTeK Computer Inc. Device [1043:1875]
Comment 1 Alex Deucher 2009-02-19 16:29:37 UTC
Does it work if you specify the busid of one of the cards in your config?
Comment 2 Julien Cristau 2009-02-23 06:38:30 UTC
On Thu, 2009-02-19 at 14:25 -0800, bugzilla-daemon@freedesktop.org
wrote:
> X gets confused by the presence of two primary graphics devices, resulting in
> "no screens found" and X exiting.  It also gives this warning:
> 
>   (!!) More than one possible primary device found

this is a dupe of #18321.
Comment 3 Bryce Harrington 2009-02-24 13:18:44 UTC
Right, marking as dupe

*** This bug has been marked as a duplicate of bug 18321 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.