Bug 2035 - External Monitor shows 640x480 panning window, not actual desktop size
Summary: External Monitor shows 640x480 panning window, not actual desktop size
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/rage128 (show other bugs)
Version: 6.7.0
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL: http://xdroop.dhs.org/space/Linux/Del...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-08 11:32 UTC by David Mackintosh
Modified: 2007-02-22 14:28 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
my xorg.conf (2.74 KB, text/plain)
2004-12-08 11:33 UTC, David Mackintosh
no flags Details
What happens when nothing is connected (34.17 KB, text/plain)
2004-12-08 11:34 UTC, David Mackintosh
no flags Details
What happens when the Acer is connected (42.40 KB, text/plain)
2004-12-08 11:34 UTC, David Mackintosh
no flags Details
What happens when the Sony is connected (51.43 KB, text/plain)
2004-12-08 11:35 UTC, David Mackintosh
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Mackintosh 2004-12-08 11:32:09 UTC
I have this new Dell D600 laptop which I have installed FC2 on. It has a SXVGA+
(ie, 1400x1050) display. X will display at this resolution (at 24-bit depth) on
the LCD display, no problem. However, when I plug the laptop into a docking
station which has an Acer 77e 17" monitor attached to it, the Acer displays the
1400x1050 desktop, as viewed through a panning 640x480 window.
Comment 1 David Mackintosh 2004-12-08 11:32:41 UTC
I have this new Dell D600 laptop which I have installed FC2 on. It has a SXVGA+
(ie, 1400x1050) display. X will display at this resolution (at 24-bit depth) on
the LCD display, no problem. However, when I plug the laptop into a docking
station which has an Acer 77e 17" monitor attached to it, the Acer displays the
1400x1050 desktop, as viewed through a panning 640x480 window.

Experimentation has shown that the presence or absence of the dock (ie just
plugging the Acer straight into the back of the Dell) makes no difference.

I know it is possible to have this monitor display 1400x1050x24 -- Windows does
it. I've also driven this monitor at 1600x1280x24 when attached to a different
linux system. I also know that it is possible to have this Linux display
properly at this resolution on an external monitor -- I have a Sony G400 at the
office which does it.

I have gone through the FC2 System Settings -> Display applet and have
explicitly defined my monitor as an AcerView 77e. I have confirmed in my
/etc/X11/xorg.conf that there is an appropriate monitor defined:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Acer 77e"
        HorizSync    30.0 - 72.0
        VertRefresh  50.0 - 120.0
EndSection

The presence and/or absence of this section doesn't appear to change anything.

When I boot the laptop at the office, it is connected to the Sony G400 and it
does the appropriate thing. At home, it still does not behave with the Acer.

In the Xorg.0.log, I've noticed that when connected to the Sony, the log reports:

(II) RADEON(0): Displays Detected: Monitor1--Type 2, Monitor2--Type 1

(II) RADEON(0): Monitor2 EDID data --------------------------- (II) RADEON(0):
Manufacturer: SNY Model: 290 Serial#: 8011257 (II) RADEON(0): Year: 2000 Week:
25 (II) RADEON(0): EDID Version: 1.2 [...lots of monitor stuff trimmed...] (II)
RADEON(0): End of Monitor2 EDID data -------------------- (II) RADEON(0): (II)
RADEON(0): Primary Display == Type 2 (II) RADEON(0): Clone Display == Type 1

...which tells me that it is detecting the Sony all by itself and making
appropriate assumptions. Where as when it is connected ot the Acer, I see:

(II) RADEON(0): Displays Detected: Monitor1--Type 2, Monitor2--Type 1

(II) RADEON(0): (II) RADEON(0): Primary Display == Type 2 (II) RADEON(0): Clone
Display == Type 1

...which tells me that either the Acer isn't detected at all, or it is detected
improperly. However, I still don't know what to do about it. I'm starting to
suspect that the config file is merely there for my amusement and xorg is trying
to auto-detect things at startup rather than read the config file.

What I can't find is an explanation as to why I'm getting this 640x480 on an
external monitor which is clearly capable of displaying much more, nor an
explanation of how to fix it. All pages on the web I've found suggest that it
means that my monitor can't run the video mode I selected (known to be false) or
that my video card can't run the video mode I selected (also known to be false).
It has to be a configuration problem.

Incidentally, a co-worker has the same problem, only he's started with FC2 and
done an "upgrade" install to FC3.
Comment 2 David Mackintosh 2004-12-08 11:33:24 UTC
Created attachment 1494 [details]
my xorg.conf
Comment 3 David Mackintosh 2004-12-08 11:34:08 UTC
Created attachment 1495 [details]
What happens when nothing is connected
Comment 4 David Mackintosh 2004-12-08 11:34:38 UTC
Created attachment 1496 [details]
What happens when the Acer is connected
Comment 5 David Mackintosh 2004-12-08 11:35:16 UTC
Created attachment 1497 [details]
What happens when the Sony is connected
Comment 6 Alex Deucher 2004-12-08 14:25:45 UTC
the radeon driver defaults to driving each display with a separate crtc (called
clone mdoe).  if it can't find the DDC data for the attached monitor it defaults
to 640x480@60Hz to avoid potentially damaging you monitor.  You can either
disable clone mode (in which case crtc1 will drive both outputs) or add the use
the clonehsync and clonevrefresh options (to tell the driver the monitor's
limits when it can't get DDC data).  see that radeon man page for more about the
options.
Comment 7 Alex Deucher 2004-12-08 14:28:20 UTC
not a bug
Comment 8 Alex Deucher 2004-12-08 14:30:22 UTC
for your coworker, in 6.8.x the options have changed a bit, see the radeon man
page for more.
Comment 9 Douglas 2004-12-28 12:48:36 UTC
(In reply to comment #6)
> the radeon driver defaults to driving each display with a separate crtc (called
> clone mdoe).  if it can't find the DDC data for the attached monitor it defaults
> to 640x480@60Hz to avoid potentially damaging you monitor.  You can either
> disable clone mode (in which case crtc1 will drive both outputs) or add the use
> the clonehsync and clonevrefresh options (to tell the driver the monitor's
> limits when it can't get DDC data).  see that radeon man page for more about the
> options.

Good Day Alex.

I am having a similar problem to the above, however my screen resolution appears
to be stuck at 1024*768.

I have tried using the CRT2HSync and CRT2VRefresh options to no avail.

Would it be possible to re-open this bug for this?

I shall provide you with my log files and configuration files.

Thank you in advance.
Comment 10 Stefan Seefeld 2005-04-06 17:34:42 UTC
I have had the same trouble described here, initially, i.e. my radeon M9
displays at 640x480 when using an external ViewSonic PF795 monitor connected
over a dock.

I added 

        Option      "CRT2HSync" "30.0 - 82.0"
        Option      "CRT2VRefresh" "50.0 - 90.0"

to my xorg.config file, but that only partly solved the problem:
The resolution seems now almost correct, but the screen is misaligned by
about 200 pixels horizontally and 50 pixels vertically. Additionally, the
truetype fonts look really aweful, which makes me think the grid used to
rasterize the fonts doesn't quite match the real pixel grid, and thus the
bad fonts could be another symptom of the same error.

Comment 11 Erik Andren 2006-04-12 07:07:51 UTC
What's the status of this bug using a current version of xorg?
Comment 12 Timo Jyrinki 2007-02-22 14:28:32 UTC
Marking broken (status null/blank) bugs in xorg with no activity in a long time as fixed. Please reopen if you think it's necessary, but first do a search if a similar bug report is already filed and in a NEW/ASSIGNED state. These bugs do not currently show in most search results as they do not have any status.

Sorry for this janitorial spam, you know where to send hate mails to when your inbox gets full of bugs you're subscribed to.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.