Bug 20432 - Can't connect anymore
Summary: Can't connect anymore
Status: RESOLVED FIXED
Alias: None
Product: Telepathy
Classification: Unclassified
Component: pymsn (show other bugs)
Version: unspecified
Hardware: Other All
: medium critical
Assignee: Ali Sabil
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-02 15:14 UTC by Guillaume Desmottes
Modified: 2009-08-05 08:04 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Desmottes 2009-03-02 15:14:46 UTC
I got this error each time I try to connect using telepathy-butterfly

DEBUG:Transport:<<< ADL 8 OK
DEBUG:Transport:>>> CHG 9 2 1879048192 
DEBUG:Transport:>>> PNG
INFO:Butterfly.Presence:Setting Presence to 'NLN'
INFO:Butterfly.Presence:Setting Personal message to ''
DEBUG:Butterfly.Aliasing:Called RequestAliases
DEBUG:Butterfly.Aliasing:Called RequestAliases
DEBUG:Butterfly.Aliasing:Called RequestAliases
DEBUG:Transport:>>> CHG 10 NLN 1879048192 
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pymsn/util/decorator.py", line 103, in process_queue
    func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/pymsn/msnp/notification.py", line 138, in set_presence
    (presence, str(client_id), urllib.quote(str(msn_object))))
  File "/usr/lib/python2.5/site-packages/pymsn/msnp/base.py", line 80, in _send_command
    callback, *cb_args)
  File "/usr/lib/python2.5/site-packages/pymsn/transport.py", line 208, in send_command_ex
    self.send_command(cmd, increment, callback, *cb_args)
  File "/usr/lib/python2.5/site-packages/pymsn/transport.py", line 273, in send_command
    self._transport.send(str(command), self.__on_command_sent, *our_cb_args)
  File "/usr/lib/python2.5/site-packages/pymsn/gnet/io/iochannel.py", line 157, in send
    assert(self._status == IoStatus.OPEN), self._status
AssertionError: 1
Comment 1 Guillaume Desmottes 2009-03-04 01:48:55 UTC
Here again, connecting to my MSN account using Pidgin solved the problem. Pidgin warned me about some roster synchronisation issues. I guess that's why butterfly wasn't able to connect.
Comment 2 Guillaume Desmottes 2009-03-04 01:50:21 UTC
Oups, I spoke too fast. Actually that didn't solve anything. I still have the same error.
Comment 3 Louis-Francis Ratté-Boulianne 2009-08-05 08:04:58 UTC
I think this crash is due to the command "CHG 9 2 1879048192" where "2" is an invalid status. When the server receives a wrong command, it just disconnects us. This bug was caused by tp-butterfly sending a telepahy presence instead of a papyon one (2 == Telepathy.PRESENCE_AVAILABLE). It should be fixed with papyon and tp-butterfly git master.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.