Bug 20462 - xdg-desktop-menu Fails Without desktop-directories Folder.
Summary: xdg-desktop-menu Fails Without desktop-directories Folder.
Status: RESOLVED MOVED
Alias: None
Product: Portland
Classification: Unclassified
Component: xdg-utils (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Portland Bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-04 08:23 UTC by Pat Suwalski
Modified: 2019-02-16 13:29 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pat Suwalski 2009-03-04 08:23:34 UTC
I am in the process of making a fairly minimalistic XFCE-based distribution. We use Thunar as the file manager, and one of the packages we would like to put on the system uses xdg-desktop-menu to install its ".desktop" file.

However, the file is never placed in /usr/share/applications, because the xdg-desktop-menu script errors out:

  "No writable system menu directory found."

The issue is we don't have anything that installs a /usr/share/desktop-directories directory. Creating one causes the script to run properly and install the ".desktop" file in /usr/share/applications. However, the desktop-directories directory still remains empty.

The bug is that I can't see any reason why xdg-desktop-menu should error out when /usr/share/desktop-directories does not exist. It installs the ".desktop" file in /usr/share/applications anyway.
Comment 1 GitLab Migration User 2019-02-16 13:29:34 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xdg/xdg-utils/issues/30.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.