Bug 20490 - PDF v1.7 asks to upgrade Adobe Reader
Summary: PDF v1.7 asks to upgrade Adobe Reader
Status: RESOLVED DUPLICATE of bug 14265
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
: 28153 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-05 06:05 UTC by Sebastien Bacher
Modified: 2011-06-19 15:18 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien Bacher 2009-03-05 06:05:01 UTC
the bug has been opened on https://bugs.launchpad.net/bugs/321720

"Evince cannot read the pdf format created with Adobe 8.1.3
This results in the file displaying the below message. Presumably, this is the message that Adobe Reader 8.1.3 and higher will save into the pdf files for readers that are only familiar with older pdf formats. This kind of monopolizing is typical of closed source programs.
------------------------------------
To view the full contents of this document, you need a later version of the PDF viewer. You can upgrade
to the latest version of Adobe Reader from www.adobe.com/products/acrobat/readstep2.html

For further support, go to www.adobe.com/support/products/acrreader.html
-----------------------------------

http://launchpadlibrarian.net/21663221/GradSurvey_pub_0001.pdf

This is a problem on all pdf readers, except newer adobe products. I have checked google's pdf reader, evince and foxit, which all seem to not work. However adobe pdf reader 9 reads this file."
Comment 1 Martin Schröder 2009-03-05 06:27:54 UTC
(In reply to comment #0)
> This is a problem on all pdf readers, except newer adobe products. I have
> checked google's pdf reader, evince and foxit, which all seem to not work.
> However adobe pdf reader 9 reads this file."

Because it uses (more or less proprietary) technology from Adobe; the content of the PDF is what is displayed by evince etc. What AR shows is something quite different...
Comment 2 Eugen Dedu 2010-02-13 13:03:46 UTC
The file at http://eugen.dedu.free.fr/a.pdf shows:
snoopy:~$ file a.pdf 
a.pdf: PDF document, version 1.7

Upon opening with evince 2.28.2 (using libpoppler 0.12.2 cairo), a dialog box appears "Password required... The document is locked and requires a password before it can be opened."

pdfcrack says it is not encrypted:
snoopy:~$ pdfcrack a.pdf 
Error: Encryption not detected (is the document password protected?)

So I suppose the problem is that the file is pdf v1.7.

Is there a method to see these files on gnu/linux...?
Comment 3 Martin Schröder 2010-02-13 13:21:00 UTC
(In reply to comment #2)
> So I suppose the problem is that the file is pdf v1.7.

No. The "problem" is that this file uses an AcroForm (see section
12.7.2 of the ISO PDF Standard). And it uses Adobe LiveCycle.

> Is there a method to see these files on gnu/linux...?

Not yet. Your patch is very welcome.
Comment 4 Albert Astals Cid 2010-02-15 10:56:17 UTC
Please, do not hijack bugs unless you are sure the root cause of the bug is the same.
Comment 5 Albert Astals Cid 2010-05-28 15:06:35 UTC
*** Bug 28153 has been marked as a duplicate of this bug. ***
Comment 6 Albert Astals Cid 2010-05-28 15:24:21 UTC
Basically the PDF uses JavaScript to change which contents to render and that's why we get the plain "dumb" text
Comment 7 Albert Astals Cid 2011-06-19 15:18:18 UTC

*** This bug has been marked as a duplicate of bug 14265 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.