Bug 20559 - gnome-update-icon reports N > 0 packages available but that's incorrect
gnome-update-icon reports N > 0 packages available but that's incorrect
Status: RESOLVED FIXED
Product: PackageKit
Classification: Unclassified
Component: backend-yum
unspecified
Other All
: medium minor
Assigned To: Richard Hughes
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 04:07 UTC by Michal Nowak
Modified: 2012-01-05 11:02 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
All-in-one img (61.67 KB, image/png)
2009-03-09 04:07 UTC, Michal Nowak
Details
Another "out of sync" screenshot (60.28 KB, image/png)
2009-03-11 01:24 UTC, Michal Nowak
Details
Verbose log from gpk-u-icon (109.24 KB, text/plain)
2009-03-16 07:05 UTC, Michal Nowak
Details
...and then it went to "normal" (21.33 KB, image/png)
2009-03-18 04:53 UTC, Michal Nowak
Details
When switched from dummy -> yum back-end packageKit is again out of sync (70.42 KB, image/png)
2009-03-23 05:14 UTC, Michal Nowak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Nowak 2009-03-09 04:07:13 UTC
Created attachment 23686 [details]
All-in-one img

See the screenshot.

gnome-update-icon reports 32 packages available for an update but zero is available. 

Then I opened gpk-update-viewer and it correctly reports zero available, so I selected "Update System Now" and it just reported 'Sorry no updates...'.

I remember I did today an update via PackageKit which contained exactly 32 packages...

(And, BTW, ``yum'' says: no updates available.)

Rawhide: gnome-packagekit-0.4.4-3.fc11.x86_64
Comment 1 Michal Nowak 2009-03-11 01:24:43 UTC
Created attachment 23750 [details]
Another "out of sync" screenshot
Comment 2 Richard Hughes 2009-03-11 03:23:16 UTC
If you run pkmon when you do an update, do you get "updates-changed" printed in the console?

If not, can you please get the output of:

killall gpk-update-icon
gpk-update-icon --verbose

when you can reproduce the problem. What's meant to happen if for one process to trigger the update, and the daemon broadcasts an updates-changed signal to all interested applications so that the new update list can be retrieved.

Also, is there a way to trigger this bug? The more detail the better. Thanks.
Comment 3 Michal Nowak 2009-03-11 04:11:05 UTC
(In reply to comment #2)

(Just before I read your reply.)

Actual situation: I was in state of "Another "out of sync" screenshot, updated and now I am in state of "All-in-one img", but it just says "3 updates available".

And now:

> If you run pkmon when you do an update, do you get "updates-changed" printed in
> the console?

I start pkmon. Output after "Update system now" from icon:

[none]...
Tasks:
#1	/504_ccebacbb_data	update-system (setup)	
Tasks:
#1	/504_ccebacbb_data	update-system (setup)	
Tasks:
#1	/504_ccebacbb_data	update-system (running)	
locked
Tasks:
#1	/504_ccebacbb_data	update-system (finished)	
unlocked
Tasks:
[none]


Error msg from PackageKit emerged, closed it. Output:

Tasks:
#1	/505_cccdbede_data	get-updates (wait)	
Tasks:
#1	/505_cccdbede_data	get-updates (setup)	
Tasks:
#1	/505_cccdbede_data	get-updates (running)	
Tasks:
#1	/505_cccdbede_data	get-updates (info)	
Tasks:
#1	/505_cccdbede_data	get-updates (download-repository)	
locked
Tasks:
#1	/505_cccdbede_data	get-updates (finished)	
unlocked
Tasks:
[none]

So, no "updates-changed" this time.

> If not, can you please get the output of:
> 
> killall gpk-update-icon
> gpk-update-icon --verbose

gpk-u-i is now killed and re-run with --verbose.

Immediate output:

TI:11:55:16	TH:0x24f3680	FI:egg-debug.c	FN:egg_debug_init,306
 - Verbose debugging 1 (on console 1)GPK_VERBOSE
TI:11:55:16	TH:0x24f3680	FI:egg-console-kit.c	FN:egg_console_kit_init,250
 - ConsoleKit session ID: /org/freedesktop/ConsoleKit/Session2
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_title,307
 - setting title: <b><big></big></b>
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_message,329
 - setting message: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_icon,280
 - setting window icon: pk-package-installed
TI:11:55:16	TH:0x24f3680	FI:gpk-auto-refresh.c	FN:pk_connection_gs_changed_cb,588
 - gnome-screensaver connection-changed: 1
TI:11:55:16	TH:0x24f3680	FI:gpk-auto-refresh.c	FN:pk_connection_gpm_changed_cb,537
 - gnome-power-manager connection-changed: 1
TI:11:55:16	TH:0x24f3680	FI:gpk-auto-refresh.c	FN:pk_connection_gpm_changed_cb,574
 - setting on battery 0
TI:11:55:16	TH:0x24f3680	FI:gpk-auto-refresh.c	FN:gpk_auto_refresh_change_state,400
 - defering action for 300 seconds
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_title,307
 - setting title: <b><big></big></b>
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_message,329
 - setting message: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_icon,280
 - setting window icon: pk-package-installed
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_title,307
 - setting title: <b><big></big></b>
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_message,329
 - setting message: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_icon,280
 - setting window icon: pk-package-installed
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_title,307
 - setting title: <b><big></big></b>
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_message,329
 - setting message: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_icon,280
 - setting window icon: pk-package-installed
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_title,307
 - setting title: <b><big></big></b>
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_message,329
 - setting message: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_icon,280
 - setting window icon: pk-package-installed
TI:11:55:16	TH:0x24f3680	FI:gpk-check-update.c	FN:pk_connection_changed_cb,387
 - connected=1
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_title,307
 - setting title: <b><big></big></b>
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_message,329
 - setting message: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_icon,280
 - setting window icon: pk-package-installed
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_title,263
 - setting window title: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_title,307
 - setting title: <b><big></big></b>
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_message,329
 - setting message: 
TI:11:55:16	TH:0x24f3680	FI:gpk-client-dialog.c	FN:gpk_client_dialog_set_window_icon,280
 - setting window icon: pk-package-installed
TI:11:55:16	TH:0x24f3680	FI:gpk-watch.c	FN:pk_connection_changed_cb,1117
 - connected=1
TI:11:55:16	TH:0x24f3680	FI:gpk-watch.c	FN:gpk_watch_refresh_icon,270
 - rescan
TI:11:55:16	TH:0x24f3680	FI:gpk-smart-icon.c	FN:gpk_smart_icon_set_icon_name,220
 - setting icon name (null)
TI:11:55:16	TH:0x24f3680	FI:gpk-watch.c	FN:gpk_watch_refresh_tooltip,144
 - refresh tooltip 0
TI:11:55:16	TH:0x24f3680	FI:gpk-watch.c	FN:gpk_watch_refresh_tooltip,183
 - nothing to show
TI:11:55:16	TH:0x24f3680	FI:gpk-firmware.c	FN:gpk_firmware_init,360
 - filename=intel-ucode\x2f06-0f-06 -> /lib/firmware/intel-ucode/06-0f-06
TI:11:55:16	TH:0x24f3680	FI:gpk-firmware.c	FN:gpk_firmware_init,377
 - requested: /lib/firmware/intel-ucode/06-0f-06
TI:11:55:16	TH:0x24f3680	FI:gpk-firmware.c	FN:gpk_firmware_remove_banned,266
 - match */intel-ucode/* for /lib/firmware/intel-ucode/06-0f-06, removing
TI:11:55:16	TH:0x24f3680	FI:gpk-hardware.c	FN:gpk_hardware_init,246
 - hardware driver checking disabled in GConf
TI:11:55:17	TH:0x24f3680	FI:gpk-smart-icon.c	FN:gpk_smart_icon_set_icon_name_cb,178
 - polling check
TI:11:55:17	TH:0x24f3680	FI:gpk-watch.c	FN:gpk_watch_set_proxies_ratelimit,1272
 - polling check
TI:11:55:17	TH:0x24f3680	FI:gpk-watch.c	FN:gpk_watch_get_proxy_http,1200
 - not using session proxy
TI:11:55:17	TH:0x24f3680	FI:gpk-watch.c	FN:gpk_watch_get_proxy_ftp,1158
 - not using session proxy
TI:11:55:17	TH:0x24f3680	FI:gpk-watch.c	FN:gpk_watch_set_proxies_ratelimit,1277
 - set proxy_http=(null), proxy_ftp=(null)
TI:12:00:17	TH:0x24f3680	FI:gpk-auto-refresh.c	FN:gpk_auto_refresh_maybe_refresh_cache,241
 - not when session active
TI:12:00:17	TH:0x24f3680	FI:gpk-auto-refresh.c	FN:gpk_auto_refresh_maybe_get_updates,308
 - not before timeout, thresh=86400, now=329
TI:12:00:17	TH:0x24f3680	FI:gpk-auto-refresh.c	FN:gpk_auto_refresh_maybe_get_upgrades,345
 - not before timeout, thresh=86400, now=4667


> when you can reproduce the problem. What's meant to happen if for one process
> to trigger the update, and the daemon broadcasts an updates-changed signal to
> all interested applications so that the new update list can be retrieved.

Not sure if I follow you, but: I tried to pull update lists via gpk-update-vievew's "Refresh", it won't help for gpk-u-i.

> Also, is there a way to trigger this bug? The more detail the better. Thanks.

Umm. Not sure. I set up PackageKit to look for updates on hourly basis. The system is Rawhide, so, the updates are pretty frequent. Will watch the ``pkmon'' and ``gpk-u-i --verbose'' for any interesting output. I bet the problem will pop up in few days but I afraid I don't have 100 % trigger, ATM.
Comment 4 Michal Nowak 2009-03-16 07:05:03 UTC
Created attachment 23914 [details]
Verbose log from gpk-u-icon

Updated like 30 of 32 packages, then installed the rest 2, but the icon still says "2 updates available".
Comment 5 Richard Hughes 2009-03-16 08:34:50 UTC
Okay, could you please install the packages being built here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1244269

and then change the value /etc/PackageKit/PackageKit.conf to have UseUpdateCache=false.

Then please killall packagekitd (as root) and then try to reproduce. I think the error is in the daemon, not the client code. Thanks.
Comment 6 Michal Nowak 2009-03-18 01:56:12 UTC
Having the setup & pkg you told me to. Did the "usual" test case: gpk-u-i popped up with 24 updates, installed 21 via gpk-u-v2 and gpk-u-i now, immediately, correctly reports: "There are 3 updates available".
Comment 7 Michal Nowak 2009-03-18 04:53:59 UTC
Created attachment 23996 [details]
...and then it went to "normal"
Comment 8 Richard Hughes 2009-03-20 05:26:45 UTC
If you change DefaultBackend to "dummy" in PackageKit.conf, can you find a way to reliably reproduce this, or is it limited to the yum backend?

If you can't reproduce with the dummy backend, can you try doing (as root):

NETWORK=TRUE /usr/share/PackageKit/helpers/yum/yumBackend.py

and then typing:

get-updates<tab>none<enter>

where <tab> is the tab key. This should bring up a list like:

allow-cancel	false
get-updates     none
allow-cancel	true
status	info
package	normal	xorg-x11-server-devel;1.6.0-13.fc11;i586;rawhide	SDK for X server driver module development
package	normal	freetype-devel;2.3.9-1.fc11;i586;rawhide	FreeType development libraries and header files
...

Then choose one of the updates, for instance xorg-x11-server-devel in my case, and type:

update-packages<tab>xorg-x11-server-devel<enter>

This should spit out:

percentage	5
allow-cancel	true
percentage	10
status	download
package	downloading	xorg-x11-server-devel;1.6.0-13.fc11;i586;rawhide	Development files for the XOrg server
...

Then again type:

get-updates<tab>none<enter>

and check that the package you just installed isn't in that list. If it's still there, it's a yum bug. You'll have to type the commands pretty quick, as the backend will exit after a few seconds of idle. Thanks.
Comment 9 Richard Hughes 2009-03-20 05:27:45 UTC
(In reply to comment #7)
> Created an attachment (id=23996) [details]
> ...and then it went to "normal"

Did you install the remaining three updates?
Comment 10 Michal Nowak 2009-03-20 11:59:55 UTC
(In reply to comment #9)
> (In reply to comment #7)
> > Created an attachment (id=23996) [details] [details]
> > ...and then it went to "normal"
> 
> Did you install the remaining three updates?
> 

Yes, I did, but don't worry the bug will be back in few days. Will try the plan you provided.
Comment 11 Michal Nowak 2009-03-23 02:31:13 UTC
(In reply to comment #8)
> If you change DefaultBackend to "dummy" in PackageKit.conf, can you find a way
> to reliably reproduce this, or is it limited to the yum backend?

Not reproducible. Usually when I know there are updates available *and* the icon is not present in bar I open, manually, gpk-u-v{,2}, it does some necessary magic and the icon is there and I can track the problem. But now the icon won't emerge, so, I am not able to track it.

(Side note: a little bit odd is that gpk-u-v2 installed all the "updates" even though I selected only `powertop' there. 

> If you can't reproduce with the dummy backend, can you try doing (as root):
> 
> NETWORK=TRUE /usr/share/PackageKit/helpers/yum/yumBackend.py

...and I still had the "dummy" set up, in case it's important.

> ...
> and check that the package you just installed isn't in that list. If it's still
> there, it's a yum bug. You'll have to type the commands pretty quick, as the
> backend will exit after a few seconds of idle. Thanks.

I installed update "rpmfusion-free-release" this way and it was not in the output after command `get-updates\tnone\n'

--
Strange is that, every other attempt to install this way a pkg (like rpmfusion-nonfree-release from the same repo) ended this way:

update-packages rpmfusion-nonfree-release
allow-cancel	false
percentage	0
status	running
status	dep-resolve
percentage	5
allow-cancel	true
percentage	10
status	download
percentage	40
status	sig-check
subpercentage	0
percentage	12610
subpercentage	100
percentage	12640
Importing GPG key 0xB1981B68 "RPM Fusion repository (Fedora - nonfree) <rpmfusion-buildsys@lists.rpmfusion.org>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora
repo-signature-required	rpmfusion-nonfree-release;10.90-2;noarch;rpmfusion-nonfree-rawhide	rpmfusion-nonfree-rawhide	/etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora	RPM Fusion repository (Fedora - nonfree) <rpmfusion-buildsys@lists.rpmfusion.org>	B1981B68	1cf26645c90e3a34d5186273206f8182b1981b68	Sat Jul 12 18:40:37 2008	gpg
error	gpg-failure	GPG key B1981B68 required
finished


But that might be a separate issue.
Comment 12 Michal Nowak 2009-03-23 05:14:23 UTC
Created attachment 24162 [details]
When switched from dummy -> yum back-end packageKit is again out of sync

I ran the proposed steps to play directly with yum back-end (comment #8).

Switched from yum -> dummy, gpk-u-i popped up with three "updates" available, switched back to yum from dummy, "Show Updates" on gpk-u-i and now I have 3 updates in gpk-u-i and 7 in gpk-u-v2. Not sure whether is this the same bug, or not. HTH.
Comment 13 Richard Hughes 2009-03-25 07:53:53 UTC
Could you please try out the packages here: http://www.packagekit.org/packages/ and tell me if this fixes the issue.
Comment 14 Michal Nowak 2009-03-25 08:04:54 UTC
If there are x86-64 binaries, I'll try it out...
Comment 15 Michal Nowak 2009-03-26 15:23:21 UTC
At least with PackageKit-0.3.14-1.fc10.i386 I noticed that the severity type of gpk-u-i's icon won't change on changed set of updates, for example from "bugfix" -> "security". Unsure of v4.

When you find time, fill the repo with x86-64 pkgs too, please. Thanks.
Comment 16 Ankur Sinha (FranciscoD) 2010-07-08 02:16:34 UTC
hi,

I think I've come across the same problem.

I just installed something using yum, and the packagekit applet showed 13 updates. I did a "yum update"successfully. The packagekit applet still shows 13 packages available for update. Clicking it gives > 

"getting information" > dialogue box pops up:  "All software is up to date"

[Ankur@localhost threadv1.0]$ rpm -q gnome-packagekit
gnome-packagekit-2.30.2-1.fc13.x86_64

ran:

[root@localhost ~]# pkcon refresh
Refreshing cache              [=========================]         
Waiting for authentication    [=========================]         
Starting                      [=========================]         
Refreshing software list      [=========================]         
Generating package lists      [=========================]       

applet still shows 13 updates as available.

regards,
Ankur

Output info from the update::


yum history info $latestHistory

Loaded plugins: auto-update-debuginfo, fastestmirror, presto, protectbase,
              : refresh-packagekit
Transaction ID : 157
Begin time     : Thu Jul  8 14:15:29 2010
Begin rpmdb    : 2336:ef2161a932b44ea79783fb3c045a94be43915ff2
End time       :            14:19:00 2010 (211 seconds)
End rpmdb      : 2337:4d7f4bcab6e1aae100b89d5ad7b9215609a6b1f7
User           : Ankur Sinha <Ankur>
Return-Code    : Success
Transaction performed with:
    Updated      rpm-4.8.1-1.fc13.x86_64
    Installed    yum-3.2.27-4.fc13.noarch
    Installed    yum-metadata-parser-1.1.4-1.fc13.x86_64
    Installed    yum-plugin-auto-update-debug-info-1.1.27-2.fc13.noarch
    Installed    yum-plugin-fastestmirror-1.1.27-2.fc13.noarch
    Installed    yum-presto-0.6.2-1.fc13.noarch
Packages Altered:
    Updated      PackageKit-0.6.5-1.fc13.x86_64
    Update                  0.6.6-1.fc13.x86_64
    Updated      PackageKit-command-not-found-0.6.5-1.fc13.x86_64
    Update                                    0.6.6-1.fc13.x86_64
    Updated      PackageKit-debuginfo-0.6.5-1.fc13.x86_64
    Update                            0.6.6-1.fc13.x86_64
    Updated      PackageKit-device-rebind-0.6.5-1.fc13.x86_64
    Update                                0.6.6-1.fc13.x86_64
    Updated      PackageKit-glib-0.6.5-1.fc13.x86_64
    Update                       0.6.6-1.fc13.x86_64
    Updated      PackageKit-gstreamer-plugin-0.6.5-1.fc13.x86_64
    Update                                   0.6.6-1.fc13.x86_64
    Updated      PackageKit-gtk-module-0.6.5-1.fc13.x86_64
    Update                             0.6.6-1.fc13.x86_64
    Updated      PackageKit-yum-0.6.5-1.fc13.x86_64
    Update                      0.6.6-1.fc13.x86_64
    Updated      PackageKit-yum-plugin-0.6.5-1.fc13.x86_64
    Update                             0.6.6-1.fc13.x86_64
    Updated      bind-libs-32:9.7.0-10.P2.fc13.x86_64
    Update                 32:9.7.1-1.fc13.x86_64
    Updated      bind-utils-32:9.7.0-10.P2.fc13.x86_64
    Update                  32:9.7.1-1.fc13.x86_64
    Updated      desktop-effects-0.8.6-1.fc13.x86_64
    Update                       0.8.7-2.fc13.x86_64
    Updated      file-5.04-4.fc13.x86_64
    Update            5.04-5.fc13.x86_64
    Updated      file-devel-5.04-4.fc13.x86_64
    Update                  5.04-5.fc13.x86_64
    Updated      file-libs-5.04-4.fc13.x86_64
    Update                 5.04-5.fc13.x86_64
    Updated      git-1.7.1-1.fc13.x86_64
    Update           1.7.1.1-1.fc13.x86_64
    Updated      groff-1.18.1.4-21.fc13.x86_64
    Update             1.18.1.4-22.fc13.x86_64
    Updated      ibus-rawcode-1.3.0.20100421-2.fc13.x86_64
    Update                    1.3.1.20100707-1.fc13.x86_64
    Updated      jwhois-4.0-19.fc13.x86_64
    Update              4.0-20.fc13.x86_64
    Updated      libcollection-0.4.0-12.fc13.x86_64
    Update                     0.4.0-15.fc13.x86_64
    Updated      libdhash-0.4.0-12.fc13.x86_64
    Update                0.4.0-15.fc13.x86_64
    Updated      libdrm-2.4.20-1.fc13.i686
    Updated      libdrm-2.4.20-1.fc13.x86_64
    Update              2.4.21-2.fc13.i686
    Update              2.4.21-2.fc13.x86_64
    Updated      libdrm-debuginfo-2.4.20-1.fc13.x86_64
    Update                        2.4.21-2.fc13.x86_64
    Updated      libdrm-devel-2.4.20-1.fc13.x86_64
    Update                    2.4.21-2.fc13.x86_64
    Updated      libini_config-0.5.0-12.fc13.x86_64
    Update                     0.5.0-15.fc13.x86_64
    Updated      libvpx-0.9.0-5.fc13.x86_64
    Update              0.9.1-2.fc13.x86_64
    Updated      m17n-db-1.5.5-3.fc13.noarch
    Update               1.5.5-4.fc13.noarch
    Updated      m17n-db-assamese-1.5.5-3.fc13.noarch
    Update                        1.5.5-4.fc13.noarch
    Updated      m17n-db-bengali-1.5.5-3.fc13.noarch
    Update                       1.5.5-4.fc13.noarch
    Updated      m17n-db-gujarati-1.5.5-3.fc13.noarch
    Update                        1.5.5-4.fc13.noarch
    Updated      m17n-db-hindi-1.5.5-3.fc13.noarch
    Update                     1.5.5-4.fc13.noarch
    Updated      m17n-db-kannada-1.5.5-3.fc13.noarch
    Update                       1.5.5-4.fc13.noarch
    Updated      m17n-db-malayalam-1.5.5-3.fc13.noarch
    Update                         1.5.5-4.fc13.noarch
    Updated      m17n-db-oriya-1.5.5-3.fc13.noarch
    Update                     1.5.5-4.fc13.noarch
    Updated      m17n-db-punjabi-1.5.5-3.fc13.noarch
    Update                       1.5.5-4.fc13.noarch
    Updated      m17n-db-sinhala-1.5.5-3.fc13.noarch
    Update                       1.5.5-4.fc13.noarch
    Updated      m17n-db-tamil-1.5.5-3.fc13.noarch
    Update                     1.5.5-4.fc13.noarch
    Updated      m17n-db-telugu-1.5.5-3.fc13.noarch
    Update                      1.5.5-4.fc13.noarch
    Updated      m17n-db-thai-1.5.5-3.fc13.noarch
    Update                    1.5.5-4.fc13.noarch
    Updated      m17n-lib-1.5.5-2.fc13.x86_64
    Update                1.5.5-3.fc13.x86_64
    Updated      net-snmp-1:5.5-12.fc13.x86_64
    Update                1:5.5-13.fc13.x86_64
    Updated      net-snmp-libs-1:5.5-12.fc13.x86_64
    Update                     1:5.5-13.fc13.x86_64
    Updated      perl-Git-1.7.1-1.fc13.noarch
    Update                1.7.1.1-1.fc13.noarch
    Updated      python-beaker-1.5.3-1.fc13.noarch
    Update                     1.5.3-3.fc13.noarch
    Updated      python-magic-5.04-4.fc13.x86_64
    Update                    5.04-5.fc13.x86_64
    Updated      python-mako-0.3.2-1.fc13.noarch
    Update                   0.3.4-1.fc13.noarch
    Dep-Install  python-markupsafe-0.9.2-3.fc13.x86_64
    Updated      python-simplejson-2.0.9-3.fc12.x86_64
    Update                         2.1.1-1.fc13.x86_64
    Updated      rpm-4.8.1-1.fc13.x86_64
    Update           4.8.1-2.fc13.x86_64
    Updated      rpm-build-4.8.1-1.fc13.x86_64
    Update                 4.8.1-2.fc13.x86_64
    Updated      rpm-devel-4.8.1-1.fc13.x86_64
    Update                 4.8.1-2.fc13.x86_64
    Updated      rpm-libs-4.8.1-1.fc13.x86_64
    Update                4.8.1-2.fc13.x86_64
    Updated      rpm-python-4.8.1-1.fc13.x86_64
    Update                  4.8.1-2.fc13.x86_64
    Updated      sssd-1.2.0-12.fc13.x86_64
    Update            1.2.1-15.fc13.x86_64
    Updated      sssd-client-1.2.0-12.fc13.x86_64
    Update                   1.2.1-15.fc13.x86_64
    Updated      tcp_wrappers-7.6-58.fc13.x86_64
    Update                    7.6-59.fc13.x86_64
    Updated      tcp_wrappers-libs-7.6-58.fc13.i686
    Updated      tcp_wrappers-libs-7.6-58.fc13.x86_64
    Update                         7.6-59.fc13.i686
    Update                         7.6-59.fc13.x86_64
Scriptlet output:
   1 warning: /etc/sssd/sssd.conf created as /etc/sssd/sssd.conf.rpmnew
   2
history info