Bug 20741 - mesa/progs/demos/engine and terrain rendering incorrect in wireframe mode
mesa/progs/demos/engine and terrain rendering incorrect in wireframe mode
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
Other Linux (All)
: medium normal
Assigned To: Ian Romanick
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 20:41 UTC by Shuang He
Modified: 2009-08-24 12:31 UTC (History)
1 user (show)

See Also:


Attachments
xorg log (22.16 KB, text/plain)
2009-03-18 20:42 UTC, Shuang He
Details
screen shot (275.69 KB, image/png)
2009-03-18 20:43 UTC, Shuang He
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shuang He 2009-03-18 20:41:22 UTC
System Environment:
--------------------------
Kernel_version:         2.6.29-rc7
Libdrm:         (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa:            (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver:         (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:      (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf
Kernel:       (for-airlied)dc529a4fe1ae4667c819437a94185e8581e1e680


Bug detailed description:
-------------------------
mesa/progs/demos/engine and terrain rendering incorrect in wireframe mode
It looks like the old frames are not cleared, while new frame is rendered.

both i915 and i965 has this issue.

reproduce steps:
------------------------
xinit &
run mesa/progs/demos/engine
change render mode to wireframe
Comment 1 Shuang He 2009-03-18 20:42:30 UTC
Created attachment 24024 [details]
xorg log
Comment 2 Shuang He 2009-03-18 20:43:31 UTC
Created attachment 24025 [details]
screen shot
Comment 3 zhao jian 2009-03-19 02:39:30 UTC
It also exists on gm45-32bit with KMS based kernel. 
G45-64 with non-KMS kernel also has such issue. 
Comment 4 zhao jian 2009-03-19 02:42:20 UTC
mesa/progs/demos/ipers also has such issue on these machines. 
Comment 5 zhao jian 2009-03-24 18:06:02 UTC
mesa/progs/demos/ray also has such issue. 
Comment 6 Eric Anholt 2009-05-15 17:48:04 UTC
Other than the text in engine, looks fine to me now.
Comment 7 Shuang He 2009-05-20 02:12:58 UTC
(In reply to comment #6)
> Other than the text in engine, looks fine to me now.
> 

yes, it's fine now. So I'm marking this as fixed
Comment 8 Shuang He 2009-05-20 02:16:02 UTC
verified against:
Libdrm:		(master)f57d7f4b0b14972f92a83f155ae8033478aa7729
Mesa:		(mesa_7_5_branch)7ce105d2e6885eeac73c59dc14c4cd59a89c1425
Xserver:		(server-1.6-branch)a9f85dcefbadfe44d8c58ad08430aaadb8c59d34
Xf86_video_intel:		(master)87332a7cc16af82aa47e07fbf90da3635b071dbf
Kernel:       (for-linus)7c7327d9664280cad833da1f14bad13a3ea8f0bf
Comment 9 ajax at nwnk dot net 2009-08-24 12:31:58 UTC
Mass version move, cvs -> git