Bug 20966 - Weird fonts with mesa-7.4 on low resolutions
Weird fonts with mesa-7.4 on low resolutions
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r200
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 00:21 UTC by smoki
Modified: 2009-04-03 01:30 UTC (History)
0 users

See Also:


Attachments
RTCW@640x480-Mesa-7.3-good (40.72 KB, image/jpeg)
2009-03-31 00:21 UTC, smoki
Details
RTCW@640x480-Mesa-7.4-bad (43.33 KB, image/jpeg)
2009-03-31 00:22 UTC, smoki
Details
RTCW@640x480-Mesa-7.4-worst (72.39 KB, image/jpeg)
2009-03-31 00:23 UTC, smoki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description smoki 2009-03-31 00:21:00 UTC
Created attachment 24390 [details]
RTCW@640x480-Mesa-7.3-good

Fonts regression on r200, they are good in 7.3<=. This can be seen in q3 based games and doom3 also. I can only noticed this on low resolution like 640x480 and 800x600, but not at 1024x768 which is my desktop resolution. Again, in 7.3<= fonts are proper at every resolutions.
Comment 1 smoki 2009-03-31 00:22:06 UTC
Created attachment 24391 [details]
RTCW@640x480-Mesa-7.4-bad
Comment 2 smoki 2009-03-31 00:23:33 UTC
Created attachment 24392 [details]
RTCW@640x480-Mesa-7.4-worst
Comment 3 Roland Scheidegger 2009-04-02 11:02:20 UTC
Confirmed. Looks like nearest filtering gets used instead of bilinear (with high enough resolution it just doesn't matter much there). git-bisect tells me it's 42ce7900865f857ff6fa07a3e0d1d910426e3633 ("mesa: refactor glTexParameter code").
I'll look into it.
Comment 4 Roland Scheidegger 2009-04-02 15:03:36 UTC
Fixed in master (ebc1478e501d43e0de54e7b6c3edfbc81d7d20c6) and mesa_7_4_branch (7be149cfd131c0b3f7d4337bb83e6fba5f563bf9).
Comment 5 smoki 2009-04-03 01:30:24 UTC
(In reply to comment #4)
> Fixed in master (ebc1478e501d43e0de54e7b6c3edfbc81d7d20c6) and mesa_7_4_branch
> (7be149cfd131c0b3f7d4337bb83e6fba5f563bf9).
> 

 Thanks, it is fixed. With that commits you have fixed dynamic lighting problem also (bug #20965).