Bug 20991 - [945GM] [XRANDR] Wrong screen dimensions when screen is rotated
Summary: [945GM] [XRANDR] Wrong screen dimensions when screen is rotated
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-01 04:12 UTC by Bastien Nocera
Modified: 2018-12-13 18:28 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xrandr-verbose.txt (5.83 KB, text/plain)
2009-04-02 10:45 UTC, Bastien Nocera
no flags Details
xrandr-verbose-rotated.txt (5.83 KB, text/plain)
2009-04-02 10:45 UTC, Bastien Nocera
no flags Details
Xorg.0.log (290.77 KB, text/plain)
2009-04-02 10:46 UTC, Bastien Nocera
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastien Nocera 2009-04-01 04:12:13 UTC
Reproduced on:
xorg-x11-server-Xorg-1.6.0-15.fc11.i586
xorg-x11-drv-intel-2.6.99.902-1.fc11.i586
(with KMS enabled)

As well as:
xorg-x11-drv-i810-2.5.0-4.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-15.fc10.x86_64
(without KMS)

xdpyinfo normal:
screen #0:
  dimensions:    1680x1050 pixels (445x278 millimeters)
  resolution:    96x96 dots per inch

xdpyinfo with the screen rotated left:
  dimensions:    1050x1680 pixels (445x278 millimeters)
  resolution:    60x153 dots per inch

The screen sizes aren't getting swapped, causing the wrong aspect ratio to be selected when playing back movies.

See the original bug:
http://bugzilla.gnome.org/show_bug.cgi?id=484454
Comment 1 Gordon Jin 2009-04-01 18:39:56 UTC
Please provide more info according to http://intellinuxgraphics.org/how_to_report_bug.html, like chipset info and Xorg.0.log.

Can you try 
xorg-x11-server-Xorg-1.6.0-15.fc11.i586
xorg-x11-drv-intel-2.6.99.902-1.fc11.i586
with KMS disabled (boot kernel with i915.modeset=0)? 
If so, attaching log with that config will be good.
Comment 2 Bastien Nocera 2009-04-02 10:44:21 UTC
I don't see why those are required, but whatever...

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

xorg-x11-drv-intel-2.6.99.902-1.fc11.i586
xorg-x11-server-Xorg-1.6.0-15.fc11.i586

$ cat /etc/X11/xorg.conf
# Xorg configuration created by pyxf86config

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
	Option     "Tiling" "False"
EndSection
Comment 3 Bastien Nocera 2009-04-02 10:45:22 UTC
Created attachment 24466 [details]
xrandr-verbose.txt

xrandr --verbose with normal orientation
Comment 4 Bastien Nocera 2009-04-02 10:45:52 UTC
Created attachment 24467 [details]
xrandr-verbose-rotated.txt

xrandr --verbose with the screen rotated to the left
Comment 5 Bastien Nocera 2009-04-02 10:46:41 UTC
Created attachment 24468 [details]
Xorg.0.log

The full Xorg server log after having done one rotation to the left, and restored the normal orientation.
Comment 6 Michael Fu 2009-09-17 19:42:39 UTC
looks like the logs you attached doesn't match your description of 

screen #0:
  dimensions:    1680x1050 pixels (445x278 millimeters)
  resolution:    96x96 dots per inch

xdpyinfo with the screen rotated left:
  dimensions:    1050x1680 pixels (445x278 millimeters)
  resolution:    60x153 dots per inch


we can't reproduce this bug any more on a Ubuntu 9.10 alpha. Can you still reproduce this bug?
Comment 7 sascha heid 2009-10-06 16:14:58 UTC
I can still reproduce this bug on both of my karmic setups.

dimensions:    1050x1400 pixels (245x184 millimeters) <- thats portrait-mode

totem is still unable to play a video with the correct aspect-ratio.
Comment 8 Bastien Nocera 2009-10-06 17:43:19 UTC
Still not switching the millimeters dimensions.

$ xrandr -q
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
VGA1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 434mm x 270mm
   1680x1050      60.0*+
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
$ xdpyinfo
[...]
screen #0:
  dimensions:    1680x1050 pixels (444x277 millimeters)
  resolution:    96x96 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
[...]

$ xrandr -o left
$ xdpyinfo
[...]
screen #0:
  dimensions:    1050x1680 pixels (444x277 millimeters)
  resolution:    60x154 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
[...]


With xorg-x11-drv-intel-2.9.0-2.fc12.x86_64
Comment 9 Eric Piel 2009-11-30 04:51:32 UTC
Still happens here with xserver 1.7.2, intel 2.9.1, and xrandr 1.3.2. The physical size is always reported landscape-wise. 
Comment 10 Michael Fu 2009-12-30 04:59:14 UTC
I found xrandr -o left doesn't swap the dimension(wrong), while xrandr --output LVDS1 --rotate left does(right)..
Comment 11 Rafi Rubin 2010-04-21 18:57:11 UTC
I'm seeing the same behavior with 1.7.6.901 and nouveau (debian unstable).

Is this a video driver, core randr, or utility (xrandr) bug?
Comment 12 Jesse Barnes 2010-07-15 10:58:16 UTC
Sounds like a generic randr problem.
Comment 13 Tom Hughes 2014-05-12 12:01:12 UTC
Is there any risk of this ever getting fixed? I'm seeing exactly the same problems as the original reporter on the Gnome bug when I run totem on a screen that is rotated.

As previously reported, xrandr is showing the pixel size as reversed on the rotated screen, but not the physical size:

Screen 0: minimum 320 x 200, current 3760 x 1600, maximum 8192 x 8192
DVI-I-1 connected primary 2560x1600+0+0 (normal left inverted right x axis y axis) 646mm x 406mm
   2560x1600      59.9* 
   1280x800       59.9  
DVI-I-2 connected 1200x1600+2560+0 right (normal left inverted right x axis y axis) 408mm x 306mm
   1600x1200      60.0*+
   1400x1050      74.9  
   1280x1024      85.0     75.0  
   1280x960       85.0  
   1152x864       85.1     75.0  
   1024x768       85.0     75.1     70.1     60.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     75.0     72.8     66.7     60.0  
   720x400        70.1  

Even trying to set the size of DVI-I-2 expicitly with --fbmm doesn't seem to help as it just reverses the values if I put the small one first!
Comment 14 sascha heid 2015-10-24 21:36:26 UTC
Still not fixed, this is pathetic.
Comment 15 Andy Green 2017-07-05 08:58:02 UTC
Guys.... I get wrong aspect ratio video out of totem on Fedora 26 beta.

It's the same on Xorg or Wayland session.

And it seems the same issue as 8 years ago

Screen 0: minimum 320 x 200, current 2160 x 3840, maximum 8192 x 8192
XWAYLAND0 connected 2160x3840+0+0 (normal left inverted right x axis y axis) 600mm x 340mm
   2160x3840     59.98*+

I guess swapping two ints when we swap two other ints is not so tremendously difficult to fix?  Or this will never be fixed and totem or some intermediate library should work around it?
Comment 16 GitLab Migration User 2018-12-13 18:28:34 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/146.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.