Bug 21094 - [KMS] Only one resolution supported on LVDS
[KMS] Only one resolution supported on LVDS
Status: VERIFIED DUPLICATE of bug 20801
Product: DRI
Classification: Unclassified
Component: DRM/Intel
XOrg git
Other Linux (All)
: medium normal
Assigned To: Gordon Jin
Depends on:
  Show dependency treegraph
Reported: 2009-04-07 23:56 UTC by zhao jian
Modified: 2009-06-16 22:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

xorg.0.log (20.41 KB, text/plain)
2009-04-07 23:56 UTC, zhao jian
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhao jian 2009-04-07 23:56:47 UTC
Created attachment 24659 [details]

System Environment:
Host:           945gm
Arch:           i386
Platform:               945GM
OSD:            Fedora release 9 (Sulphur)
Libdrm:             (master)1faab66cfd1a854925da6ff7109aa614292dea90
Mesa:               (mesa_7_4_branch)de197cf991416f0cd65ad2e2d2ca9aa599b52075
Xserver:            (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:   (2.7)3e5586cace98f73a9f8403a6446d380899ecbce9
Kernel:             (drm-intel-2.6.29)71d7aec4bbf923eaf43563c03459726a746cd332

Bug Description:
On the laptops, use KMS kernel, start X and run 'xrandr -q', there is only one display mode under LVDS. With UMS, there are many display modes.  

Reproduce steps:
2.xrandr -q
Comment 1 Gordon Jin 2009-04-08 00:12:37 UTC
known issue, marking dup.

*** This bug has been marked as a duplicate of bug 20801 ***
Comment 2 liuhaien 2009-06-16 22:41:42 UTC
verified with below commits:
Libdrm:         (master)3d4bfe8c893d016ef43d1ebf28e4607aa1f540a4
Mesa:           (master)1510c3cae1d840a065a22c891ad6db794dfe7a00
Xserver:                (master)b2d2af76b43d62c9be07fd736652f904632fd663
Kernel:       (for-linus)0e7ddf7eeeef5aea85412120539ab5369577faeb