Bug 21246 - [GM965 KMS] Tiling corrupts screen with 2.7.0
[GM965 KMS] Tiling corrupts screen with 2.7.0
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Gordon Jin
Xorg Project Team
:
: 21276 21411 21437 21460 21486 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-17 07:32 UTC by Sander Jansen
Modified: 2009-05-14 07:53 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
The xorg log when the tiling is enabled. (16.55 KB, application/octet-stream)
2009-04-17 07:32 UTC, Sander Jansen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sander Jansen 2009-04-17 07:32:55 UTC
Created attachment 24894 [details]
The xorg log when the tiling is enabled.

Using the 2.7.0 release, the display gets messed up, as if the screen is somehow out of sync, making it totally unusable. Note that it seems to run fine, it doesn't crash, but it's hard to see what's drawn on the screen. I don't use a xorg.conf for this setup.

When I disable tiling however, everything seems to run fine, so I'm gussing it's a tiling bug :)
Comment 1 Matthew Cox 2009-04-18 14:46:03 UTC
I can also reproduce this bug, and I can help pin down when it was introduced. The source repo for this package in ArchLinux is available here.
http://repos.archlinux.org/viewvc.cgi/xf86-video-intel/trunk/PKGBUILD?view=log

Revision 35727 has this bug, while 32224 does not. I haven't checked the intermediate revision, as it's an older version of the driver with a patch to fix the Xv lockup issue. The 32224 revision of the driver is a snapshot of the 2.7 branch.
Comment 2 Matthew Cox 2009-04-18 14:50:54 UTC
Just as an amendment to my previous comment, the 32224 revision of the package includes a patch which appears to be a git-diff produced patch to bring commit 1d19b024dba970e4b24daccb898101f77d5529ff (which I assume is the same tree that was released as 2.6.999) up to e2465249a90b9aefe6d7a96eb56a51fde54698a0. This latter commit then, doesn't have the tiling bug.
Comment 3 Gordon Jin 2009-04-19 22:31:29 UTC
Using 2.7.0 with KMS needs this kernel fix:
http://git.kernel.org/?p=linux/kernel/git/anholt/drm-intel.git;a=commit;h=f544847fbaf099278343f875987a983f2b913134

It should go into upstream kernel soon, if it hasn't.

Please reopen if you find this patch not help.
Comment 4 Mike Kelly 2009-04-20 06:38:56 UTC
*** Bug 21276 has been marked as a duplicate of this bug. ***
Comment 5 Gordon Jin 2009-04-26 07:12:48 UTC
*** Bug 21411 has been marked as a duplicate of this bug. ***
Comment 6 Gordon Jin 2009-04-27 22:10:13 UTC
*** Bug 21437 has been marked as a duplicate of this bug. ***
Comment 7 Gordon Jin 2009-04-28 06:11:01 UTC
*** Bug 21460 has been marked as a duplicate of this bug. ***
Comment 8 Gordon Jin 2009-05-03 22:09:27 UTC
*** Bug 21486 has been marked as a duplicate of this bug. ***
Comment 9 Sander Jansen 2009-05-13 16:55:28 UTC
Just upgraded to kernel 2.6.29.3 which contained the tiling bugfix and has fixed the issue for me.

Thanks, Sander
Comment 10 Nicolas Bigaouette 2009-05-14 07:53:15 UTC
I'm using xf86-video-intel 2.7.1 with kernel 2.6.29.3 from ArchLinux. I have this problem if I don't set this as my xorg.conf:
Section "Device"
    Identifier "mydevice"
    Driver "intel"
    Option "Tiling" "false"
EndSection

Was the patch proposed in comment #3 is included in 2.6.29.3?