Bug 21269 - Wants to install packages for all architectures
Summary: Wants to install packages for all architectures
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-yum (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-18 11:05 UTC by Owen Taylor
Modified: 2009-08-10 03:45 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Taylor 2009-04-18 11:05:04 UTC
On an x86_64 Fedora Rawhide system

 gpk-install-package-name gstreamer-devel 

Wants to install both i586 and x86_64 packages of everything, while:

 yum install gstreamer-devel 

Only installs the x86_64 packages. Maybe this is intentional, but it seems strange to me.
Comment 1 Owen Taylor 2009-08-06 12:45:10 UTC
Any progress here? 

(This is making things very unpleasant for people trying to build gnome-shell on x86_64, we use gpk-install-package-name to install missing deps, but it fails for x86_64 because of this problem and conflicts, so people do things manually and miss packages, and have weird problems 10 minutes into the build...)



Comment 2 Richard Hughes 2009-08-10 03:45:58 UTC
Sorry for the delay!

commit 031734781e2c4d922ea24e2c3cdcfadf769359bb
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Aug 10 10:56:30 2009 +0100

    Only install the newest native-arch package when using the session methods. Fixes rh#509569

:100644 100644 d011f85... 7c53cd0... M  src/gpk-dbus-task.c


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.