Bug 21305 - APT-RPM backend?
Summary: APT-RPM backend?
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: low enhancement
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-20 12:03 UTC by viper550
Modified: 2018-08-21 15:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description viper550 2009-04-20 12:03:28 UTC
We got a Linux distribution over here called Ark Linux, and I'm trying to rid it of the ancient Kynaptic package manager for good. But, we happen to use apt-rpm as our package manager backend.

Think its possible to set up a APT-RPM backend?
Comment 1 viper550 2009-04-20 13:28:52 UTC
oh yeah I forgot, this may benefit PCLinuxOS too, which is a pretty major distro too.
Comment 2 Richard Hughes 2009-04-21 00:30:25 UTC
Sure! We welcome new backends. Would this work with the existing apt or aptcc backends, or do you need to create a new backend from scratch?
Comment 3 viper550 2009-04-21 05:06:55 UTC
This may need to be reworked, I inspected the APT backend code, it calls DPKG alot.
Comment 4 Richard Hughes 2009-04-21 05:21:10 UTC
Sure, in which case a new backend (apt-rpm?) might be best. Join the PackageKit  mailing list, introduce yourself, and start hacking :-)
Comment 5 Richard Hughes 2018-08-21 15:52:59 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.