Bug 21326 - [945GM] XVideo usage crashes the server when DRI is disabled
Summary: [945GM] XVideo usage crashes the server when DRI is disabled
Status: RESOLVED DUPLICATE of bug 21060
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-21 14:04 UTC by Ben Schwartz
Modified: 2009-04-21 18:00 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (536 bytes, text/plain)
2009-04-21 14:04 UTC, Ben Schwartz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Schwartz 2009-04-21 14:04:14 UTC
Created attachment 25015 [details]
xorg.conf

I have two monitors, one 1024x768 and one 1440x900.  I often run with them side by side, using Xrandr.  To make this work, I need an xorg.conf with the line "Virtual 2464 1024".  /var/log/Xorg.0.log then shows

(EE) intel(0): Cannot support DRI with frame buffer width > 2048.

which is fine; I don't use 3D accel, so I don't need DRI.

Under xserver-1.3 and xf86-video-intel-2.1.1, this was fine.  Even without DRI, Xvideo continued to work fine.

When I upgraded to xserver-1.5.3 and xf86-video-intel-2.6.3, Xvideo stopped working.  Now, whenever I play a video using xvideo, the server crashes.  Usually, it crashes immediately upon playback initiating, but occasionally it shows stranger behaviors, like corrupting one line of the video, and then crashing when the video is closed.  This is a major regression.

If I shrink the virtual display, so that DRI can be enabled, then Xvideo works fine.  I haven't been able to get any logs from the crashes; the X server restarts and seems to overwrite its log files.  I don't know if there's anything to see in the logs.
Comment 1 Ben Schwartz 2009-04-21 14:24:50 UTC
I just decided to test it again, and this time I got a totally hard lockup, complete with psychedelic flashing bars.  It even forced a kernel panic, flashing-capslock included.

I guess that means it's a kernel issue too, so here's my uname -a:

Linux bemasc 2.6.27-gentoo-r7 #1 SMP PREEMPT Wed Mar 4 15:12:36 EST 2009 i686 Genuine Intel(R) CPU L2400 @ 1.66GHz GenuineIntel GNU/Linux

It's pretty much a standard vanilla-ish kernel.  No KMS, AFAIK.
Comment 2 Gordon Jin 2009-04-21 18:00:15 UTC
looks a dup.

*** This bug has been marked as a duplicate of bug 21060 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.