Bug 21346 - [LVDS] Not detecting all valid modes
[LVDS] Not detecting all valid modes
Status: RESOLVED DUPLICATE of bug 20801
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
Other All
: medium normal
Assigned To: Gordon Jin
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 15:07 UTC by Michael Monreal
Modified: 2009-04-22 19:30 UTC (History)
0 users

See Also:


Attachments
xrandr output (418 bytes, text/plain)
2009-04-22 15:08 UTC, Michael Monreal
no flags Details
Xorg.log (63.14 KB, text/plain)
2009-04-22 15:09 UTC, Michael Monreal
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Monreal 2009-04-22 15:07:39 UTC
[ more or less forwarding from http://www.earlconsult.com/mantis/view.php?id=27 ]

With the 7.4 intel driver I can only use 1280x800 resolution (native) on my notebook. Other modes are supported by the hardware, but the driver does not setup those correctly:

...
(II) intel(0): Not using default mode "800x600" (vrefresh out of range)
...

It would be great to at least have some common resolutions like 800x600 available for games etc.

Maybe related to this problem: xrandr shows some default modes for "TV1" (but not LVDS1) while my notebook does _not_ have a TV-out at all.
Comment 1 Michael Monreal 2009-04-22 15:08:58 UTC
Created attachment 25047 [details]
xrandr output
Comment 2 Michael Monreal 2009-04-22 15:09:10 UTC
Created attachment 25048 [details]
Xorg.log
Comment 3 Gordon Jin 2009-04-22 19:18:49 UTC
This is a known issue in kernel mode setting.

*** This bug has been marked as a duplicate of bug 20281 ***
Comment 4 Gordon Jin 2009-04-22 19:30:32 UTC
sorry, made a wrong dup number.

*** This bug has been marked as a duplicate of bug 20801 ***