Bug 21396 - dual screen; one card; second screen black
Summary: dual screen; one card; second screen black
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/radeonhd (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86-64 (AMD64) other
: medium normal
Assignee: Luc Verhaegen
QA Contact: Xorg Project Team
Depends on:
Reported: 2009-04-24 15:35 UTC by Andrwe Lord Weber
Modified: 2011-11-07 15:31 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Xorg.0.log starting X verbosity 7 (162.79 KB, text/plain)
2009-04-24 15:35 UTC, Andrwe Lord Weber
no flags Details
xrandr output using --verbose (10.99 KB, text/plain)
2009-04-24 15:37 UTC, Andrwe Lord Weber
no flags Details
update of Xorg.log after using git-sources (292.61 KB, text/plain)
2009-05-28 13:55 UTC, Andrwe Lord Weber
no flags Details

Description Andrwe Lord Weber 2009-04-24 15:35:24 UTC
Created attachment 25125 [details]
Xorg.0.log starting X verbosity 7

OS: Gentoo-sources-2.6.29-r1
Xorg: Xorg-server-1.5.3-r5
driver: radeonhd-1.2.5 (local-overlay); xrandr-1.2.3
DE: XFCE4-4.6.1
graphic card: Radeon HD 4670 (MSI R4670)


I can't get my second port of the graphic card working.
I'm using 2 monitors the one plugged into the first port of my card always show X fine but the second one does only show a black screen or grey small vertical stripes on black background.
If I set something like a resolution using xrandr the second monitor reacts for a short time and shows a gray big grey horizontal stripe.

I tested the card against failures using Windows Vista and the vesa driver. Both display the desktop on both monitors which means the card isn't broken and both monitors are working.

One monitor is connected using DVI and the other using VGA with DVI-VGA converter.

I tried forcing a resolution for both screens and setting up dual screen in Xorg.conf.

Comment 1 Andrwe Lord Weber 2009-04-24 15:37:12 UTC
Created attachment 25126 [details]
xrandr output using --verbose
Comment 2 Andrwe Lord Weber 2009-05-28 13:49:26 UTC
I now tried with git-sources-2.6.30_rc7-r2, radeonhd-1.2.5 of portage and xrandr-1.3.0 but it's the same result.
Comment 3 Andrwe Lord Weber 2009-05-28 13:55:51 UTC
Created attachment 26283 [details]
update of Xorg.log after using git-sources
Comment 4 Jeremy Huddleston Sequoia 2011-10-16 15:57:21 UTC
Does this issue occur with the preferred ati driver (xf86-vide-ati)?  If so, please move this to the Driver/Radeon component.  

Development of radeonhd has pretty much halted and development focus is on the ati driver.  Please see http://www.x.org/wiki/radeonhd

If the issue does not exist in the ati driver (or if there is no response to this message), this bug will be closed as WONTFIX unless someone contributes a patch.
Comment 5 Jeremy Huddleston Sequoia 2011-11-07 15:31:20 UTC
Closing due to lack of response.  Please reopen and move to the Driver/Radeon 
component if this issue persists with xf86-video-ati

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.