Bug 21519 - New libtool causes another build error (?)
Summary: New libtool causes another build error (?)
Status: RESOLVED DUPLICATE of bug 21518
Alias: None
Product: UIM
Classification: Unclassified
Component: Other (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: uim-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-02 02:22 UTC by UTUMI Hirosi
Modified: 2009-05-02 07:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description UTUMI Hirosi 2009-05-02 02:22:43 UTC
I applied my patch [Bug 21518], but uim shows another error.
//
make[3]: Entering directory `~/rpm/BUILD/uim-1.5.5/qt4/immodule'
rm -f libuiminputcontextplugin.so
g++ -Wl,--as-needed -Wl,--no-undefined -Wl,-z,relro -Wl,-O1 -shared -o libuiminputcontextplugin.so plugin.o qhelpermanager.o quiminputcontext.o quiminputcontext_compose.o candidatewindow.o subwindow.o quiminfomanager.o qtextutil.o moc_qhelpermanager.o moc_quiminputcontext.o moc_plugin.o moc_candidatewindow.o moc_subwindow.o moc_qtextutil.o   -L~/rpm/BUILD/uim-1.5.5/uim -L~/rpm/BUILD/uim-1.5.5/replace -L~/rpm/BUILD/uim-1.5.5/replace/.libs -L~/rpm/BUILD/uim-1.5.5/uim/.libs -L/usr/lib64 -lreplace -luim -luim-scm -luim-x-util -lQt3Support -L/usr/lib64 -lQtSql -pthread -pthread -pthread -pthread -lQtXml -pthread -pthread -pthread -pthread -L/usr/lib -pthread -pthread -pthread -pthread -pthread -pthread -lQtNetwork -pthread -pthread -pthread -pthread -pthread -pthread -lQtGui -pthread -lpng -lfreetype -lgobject-2.0 -lSM -lICE -pthread -pthread -lXrender -lfontconfig -lXext -lX11 -lQtCore -lz -lm -pthread -lgthread-2.0 -lrt -lglib-2.0 -lpthread -ldl 
/usr/bin/ld: cannot find -lreplace
collect2: ld returned 1 exit status
make[3]: *** [libuiminputcontextplugin.so] Error 1
make[3]: Leaving directory `~/rpm/BUILD/uim-1.5.5/qt4/immodule'
make[2]: *** [all] Error 2
//

I can avoid this error by using "--without-qt4-immodule" option.

I'm using qt4-4.5.0 on Mandriva 2009.1.
(Mandriva 2009.0: qt4-4.4.3)
Comment 1 Etsushi Kato 2009-05-02 07:26:39 UTC

*** This bug has been marked as a duplicate of bug 21518 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.