Bug 21671 - [KMS] not detecting all the modes for LVDS1
[KMS] not detecting all the modes for LVDS1
Status: RESOLVED DUPLICATE of bug 20801
Product: DRI
Classification: Unclassified
Component: DRM/Intel
XOrg git
Other All
: medium normal
Assigned To: Gordon Jin
Depends on:
  Show dependency treegraph
Reported: 2009-05-10 23:24 UTC by Mike Kelly
Modified: 2009-05-10 23:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg.0.log snippet (1.90 KB, text/plain)
2009-05-10 23:25 UTC, Mike Kelly
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kelly 2009-05-10 23:24:42 UTC
Currently using 2.6.30-rc4-tuxonice, xorg-server 1.6.1, xf86-video-intel 2.7.0.
I have a 965GM.

One of the regressions I am experiencing since switching to KMS is that it seems I can no longer change the video mode of my laptop's display. The only mode it detects is 1280x800, which is fine most of the time, except for when I want to run certain full screen programs that want to change the video mode.

I used to be able to switch to different modes, down to 320x200, w/o any effort on my part. Is this a known issue or weird config on my part?

I'm attaching what seems to be the relevant part of my Xorg.0.log

I can supply more logs, configs, etc, just don't know which would be most useful to you.
Comment 1 Mike Kelly 2009-05-10 23:25:18 UTC
Created attachment 25720 [details]
Xorg.0.log snippet
Comment 2 Gordon Jin 2009-05-10 23:41:18 UTC
This is a known issue.

*** This bug has been marked as a duplicate of bug 20801 ***