Bug 21747 - packagekit apt backend does not install packages from utf8 defined paths
Summary: packagekit apt backend does not install packages from utf8 defined paths
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-apt (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Sebastian Heinlein
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-15 03:25 UTC by Laur Mõtus
Modified: 2009-11-16 14:57 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
packagekit apt backend utf8 fix (1.26 KB, patch)
2009-05-15 03:25 UTC, Laur Mõtus
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Laur Mõtus 2009-05-15 03:25:10 UTC
Created attachment 25888 [details] [review]
packagekit apt backend utf8 fix

Ubuntu Jaunty, packagekit version 0.3.14-0ubuntu5

Packagekit apt backend does not install packages from folders that contain characters such as "ö" "ä" "ü" "õ"

This is a problem because the default path to download files - the desktop in Estonian and Finnish languages contains such characters, so when a user downloads a package file to the default location offered by the system he/she gets an non explaining error and the package won't be installed.

Link to the original bugreport:
https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/347327

Patch proposal from Estobuntu project attached.
Comment 1 Sebastian Heinlein 2009-11-16 14:57:07 UTC
This is fixed in the 0.5 series


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.